Pix4Dmapper guide to troubleshoot issues

Follow

Was this article helpful?
7 out of 37 found this helpful

Article feedback (for troubleshooting, post here)

53 comments

  • Ezio Zaid

    Good morning, take a few flights with 2 drone models (mavic 2 pro and phantom 4 pro) which were processed and have Control points, but the following is displayed in the workspace (is it normal or does it alter the model?) :

     

     

     

    Es normal?

     

     

     

    Adjunto el reporte de Calidad [link removed]

    Edited by Ezio Zaid
  • Avatar
    Marco (Pix4D)

    Hola Ezio,

    Mirando sus capturas de pantalla, podemos ver que algunas de las posiciones de las cámaras computadas están ubicadas debajo del modelo mientras que la mitad de ellas han sido computadas junto a su posición inicial.
    Mi suposición es que una de sus cámaras ha sido calculada como se ve. Tal vez el Mavic.
    En este punto, me gustaría mencionar que no es recomendable procesar juntos dos cámaras diferentes que tal diferencia de resolución (20Mpx VS 12Mpx).
    Por lo tanto, le recomendaría que las procese por separado y luego fusione los dos proyectos.

    How-to-merge-projects

    Saludos

  • sofia perabo

    Hola, hace dos dias que intento comprar una licencia de pix 4d mapper y aparece : Lo sentimos, su transacción no pudo ser procesada. Póngase en contacto con nosotros o con su proveedor de pagos para obtener más detalles.

    Espero puedan ayudarme

  • Avatar
    Marco (Pix4D)

    Hola sofia perabo,

    ¿Podría ponerse en contacto con nuestro equipo de ventas a través del enlace que nos envió?
    Ellos se asegurarán de que usted pueda comprar su licencia.
    Además, me gustaría añadir que no puede obtener más de 2 licencias de prueba.

    Saludos

  • Juan Estrada

    BUENA TARDE TENGO UN PROBLEMA CON MI ORTOMOSAICO YA QUE EN LAS ORILLAS DE LA ESTRUCTURA COMO LO MUESTRO EN LA IMAGEN SE MUESTRAN FORMAS COMO GELATINOSAS LAS CUALES ME ALTERAN MIS DATOS DE MDS YA QUE ES EL QUE ME INTERESA, YA REALICE LA MODIFICACIÓN CON EL EDITOR DE MOSAICO EL CUAL MEJORO MUCHO PERO EL MDS SIGUE CONSIDERANDO ESAS MALFORMACIONES.

  • Blaž (Pix4D)

    Hi Juan, the structure is most probably wrongly reconstructed due to the noise in the dense point cloud. I would recommend checking the dense point cloud and removing the noise points before running Step 3. again using the Point Cloud Editor.

    We recommend checking the following articles with detailed step-by-step instructions :

  • Ezio Zaid

    Hola amigos, tengo un inconveniente al momento de generar el DTM ya que en la nube de Puntos densificada se realizó el filtrado y asociación al Grupo Deshabilitado de los puentes, como se muestra en la Imagen1, luego se procedió a generar el DTM pero me muestra una elevación en esa zona libre como se visualiza en la Imagen2.

    Por favor solicito su apoyo con este problema.

    Muy agradecido.

    Imagen1. Se Muestra el filtrado de los puentes en la Nube de Puntos Puntos Densa.

     

    Imagen2. Se muestra el DTM  generado en Pix4D y la elevación del Puente que se filtro previamente.

     

     

     

  • Kapil (Pix4D)

    Hello, The elevation is most probably the result of the wrong classification of the point cloud group or due to the noise present in the model. I would recommend checking the dense point cloud and removing the noise points before running Step 3. again using the  Point Cloud Editor. Just to let you know, after point cloud editing, save the project and run step 3 only. You shouldn't run step 2 again. Can you also forward the quality report so that I can see if there is any issue while processing?

  • Ezio Zaid

    Estimado Kapil , realice el filtrado de la Nube de Puntos y elimine el ruido, solo deje los grupos de puntos Ground and Road Surface.

    Luego Inserte Surface en la parte donde se retiro el puente y quedo la nube de puntos vacía.

    Pero no mejoro mucho el resultado final.

     

     

    Te adjunto el Reporte de calidad. [link removed]

     

    Te agradeceria el apoyo para la comunidad pix4d.

  • Blaž (Pix4D)

    Hi Ezio,

    the workflow that you follow is correct and it is possible to use surfaces to make a part of the model flat or to fill the holes in the model. 

    Where you draw the surface, the model should become flat regardless of the classification. 

    Could you try processing Step 3. again and let us know if the issues remains?

  • Fred Aboagye-Larbi

    How do I upload 25000 images for processed?

  • Ibrahim Saleh

    Good evening my proffessional colleaques, i formatted my system and i reinstalled the sofware but is not opening new project though i iattemted installing on one of my second system. kindly advice please. 

  • Kapil (Pix4D)

    Hello, 

    Your license is already activated under your account so you don't need to activate anymore. I have deactivated the device that was active under your account. You can simply log out of the Pix4Ddiscovery mode and then login back to access your license. For more information, visit Step 3 processing option is not available: Discovery mode.

  • Eduardo Bieñkowski

    Tengo el siguiente problema, no logro ver el mapa de background cuando cargo las imágenes y los puntos de control.

     

     

    Saludos

     

  • Christina (Pix4D)

    Hola! Esto se soluciona con la nueva version Pix4Dmapper 4.6.3

    Para mas informacion sobre el problema: Mapbox basemap issue with older versions of Pix4D’s software

  • suhib bani amerah

    i have aproblem when i add a gcps it appears above the model

    how can i solve this

     

     

    Edited by suhib bani amerah
  • Christina (Pix4D)
  • NATE clark

    Hello,

       I have been using Pix4D Mapper for a while now without any problems. In the last 2 months or so (it's happened on several different projects) when it gets to step 3 (DSM, Orthomosaic and Index) it starts to run then shuts my computer down. The last time I ran it, it got to the generate DSM process then it just shuts down my computer. I don't get an error message and it has worked very well in the past. I am attaching two sheets of the quality report. With some info on it. I un-installed and re-installed the program last night and it is still doing it. I really need this to work again so I can get my jobs done and to clients on time.

                Thank you for your help, Nate

  • Kapil (Pix4D)

    Hi Nate, 

    We are dealing with the issue through personal support which is more convenient. If we find anything new, I will post it here so that it will be helpful for other users.

  • Fitsum Tilahun Teshome

    Hi pix4D users, 

    Recently I tried to process a thermal image using "ThermoMAP camera" processing option in pix4d. However, constantly getting "generate index failed" error. what can I do to solve this problem. or which processing option is best to process Zenmuse XT2 camera thermal image? 

    Thank you.

  • Avatar
    Momtanu (Pix4D)

    Hi, Can you send us the logfile and p4d file? You can disable all index maps formulae in the processing options and process step 3 again. Then click on index calculator. Does it work?

  • Holt Harrison

    I have used, in the past, but not lately the Pix4d Mapper Android App on my Epson Moverio BT 300.

    Upon login attempts now it says that the server is not responding and that is it.

    The only thing I can think of is a recent upgrade to the Browser app from Moverio.

    I love the glasses and would really like to continue using them, any ideas about a workaround? Capturing the correct photography for many of my projects these automated flights are needed. See site WwW.Kamera-Man.com  

    Thanks,

    Holt 

     

  • Christina (Pix4D)

    Hi Holt, unfortunately, we do not have experience with the Epson Moverio BT 300.

    I suggest you post a new topic on our Community in case other customers with similar experience can help you.

Article is closed for comments.