How to use a processing area in Pix4Dmapper

   
 
Important:
  • Only one processing area can be drawn or imported per project.
  • It is recommended to exclude areas of low overlap that could affect the results.
  • In Menu Process > Processing Options... > 2. Point Cloud and Mesh > Advanced, the box next to Use Processing Area has to be checked for the processing area to affect the display in the rayCloud view and to have an effect during the processing of step 2. Point Cloud and Mesh.

Effects of a processing area

A processing area is an area that restricts the point cloud data displayed and the extent of outputs generated for a project.

Effect on processing speed

Drawing a processing area can help increase the processing speed of step 2. Point Cloud and Mesh and step 3. DSM, Orthomosaic and Index.

 
Tip: If you want to include the whole project extent to generate results, consider drawing a processing area that is larger than the project area.

Effect on the results and display

If there is a processing area before processing step 2. Point Cloud and Mesh:

  • Results of step 1. Initial processing will not be affected.
  • The display of the automatic tie points will be affected.
  • Results of step 2. Point Cloud and Mesh and step 3. DSM, Orthomosaic and Index will be affected.
 
Tip: In Menu Process > Processing Options... > 2. Point Cloud and Mesh > Advanced, the box next to Use Processing Area has to be checked for the processing area to:
  • Affect the display in the rayCloud view.
  • Have an effect during the processing of step 2. Point Cloud and Mesh.

If there is a processing area after processing step 2. Point Cloud and Mesh:

  • Results of step 1. Initial processing and step 2. Point Cloud and Mesh will not be affected.
  • The display of the automatic tie points and the dense point cloud will be affected.
  • The dense point cloud exported through the list of layers will be affected. For more information about how to export the point cloud: How to export the point cloud.
  • The 3D textured mesh generated after step 2. Point Cloud and Mesh will be affected.
  • Results of step 3. DSM, Orthomosaic and Index will be affected.

If there is a processing area after processing step 3. DSM, Orthomosaic and Index:

  • Results of step 1. Initial processing, step 2. Point Cloud and Mesh, and step 3. DSM, Orthomosaic and Index will not be affected.
  • The display of the automatic tie points and the dense point cloud will be affected.
  • The dense point cloud exported through the list of layers will be affected. For more information about how to export the point cloud: How to export the point cloud.
  • The 3D textured mesh generated after step 2. Point Cloud and Mesh will be affected.
  • The digital terrain model (DTM) and the contour lines generated after step 3. DSM, Orthomosaic and Index will not be affected.

How to draw a processing area in the Map View

 
Access: A processing area can be drawn in the Map View:
  • As soon as a project is created.
  • If the project has geolocation information, either image geotags or ground control points (GCPs).
  • If the output coordinate system is not arbitrary.
  1. On the menu bar, click ViewMap View.
    View_Map_View.jpg
  2. On the menu bar, click Map ViewProcessing AreaDraw.
    2._Map_view_Draw.jpg
  3. On the pop-up window, click OK.
    3._i0012.jpg
  4. Left-click to place the first vertex then release the mouse button.
  5. Move your mouse and left-click to place the next vertices then release the mouse button.
  6. Right-click for the last vertex to close the polygon. 
  7. Click ProjectSave Project to save the processing area in the project.
    4._Project_Save.jpg

How to import a processing area in the Map View

 
Access: A processing area can be imported in the Map View:
  • As soon as a project is created.
  • If the project has geolocation information, either image geotags or ground control points (GCPs).
  • If the output coordinate system is not arbitrary.
  1. On the menu bar, click ViewMap View.
    5._View_Map_View.jpg
  2. On the menu bar, click Map ViewProcessing AreaImport...
    6._Processing_area_Import.jpg
  3. Select a file in the SHP or KML format.
  4. Click ProjectSave Project to save the processing area in the project.
    7._Project_Save.jpg

How to edit a processing area in the Map View

  1. On the menu bar, click ViewMap View.
    8a._View_Map_View.jpg
  2. On the menu bar, click Map ViewProcessing Area > Edit...
    9._Processing_area_Edit.jpg
  3. Double-click a cell to edit a vertex coordinate.
    10._Processing_area_Edit_vertex.jpg
  4. Click ProjectSave Project to save the processing area in the project.
    11._Project_Save.jpg
 
Tip: You can consider removing the processing area by clicking Map ViewProcessing Area > Remove then drawing it again from scratch or importing it.

How to draw a processing area in the rayCloud

 
Access: A processing area can be drawn in the rayCloud:
  • After step 1. Initial processing is completed.
  • Whether the project has geolocation information, such as image geotags or ground control points (GCPs), or not.
  • Whether an output coordinate system is defined or arbitrary.
      1. On the menu bar, click View > rayCloud.
        12a._View_rayCloud.jpg
      2. On the menu bar, click rayCloudNew Processing Area.
        13._rayCloud_new_Processing_area.jpg
      3. Left-click to place the first vertex then release the mouse button.
      4. Move your mouse and left-click to place the next vertices then release the mouse button.
      5. Right-click for the last vertex to close the polygon.
         
        Tip: Objects as well as ground control points (GCPs) and manual tie points (MTPs) are displayed even if they lie outside the area.
      6. Click ProjectSave Project to save the processing area in the project.
        14._Project_Save.jpg

How to edit a processing area in the rayCloud

 
Access: A processing area can be edited in the rayCloud after step 1. Initial processing is completed.
  1. On the menu bar, click View > rayCloud.
    15a._View_rayCloud.jpg
  2. Under Layers, check the box next to Processing Area to show the layer in the rayCloud.
    16._Layers_processing_area.jpg
  3. Under Layers, click Processing area to select the layer.
  4. In the rayCloud view, left-click the vertex you would like to edit then release the mouse button.
    17._ProcessingArea_densification_area_vertex.jpg
  5. Click the vertex again, drag it to its new position then release the mouse button.
  6. If necessary, in the right sidebar, change the Maximum altitude and/or the Minimum altitude to edit the thickness of the processing area. For more information: Menu View > rayCloud > Right sidebar > Processing Area.
  7. Click ProjectSave Project to save the processing area in the project.
    18._Project_Save.jpg
Was this article helpful?
17 out of 24 found this helpful

Article feedback (for troubleshooting, post here)

0 comments

Please sign in to leave a comment.