Troubleshooting

Error e9034: Problem uploading item to the cloud - PIX4Dmapper

 

Error

Error e9034: Problem uploading item to the cloud.

Description

When uploading the project files to PIX4Dcloud for processing, the upload fails and the error with the message Error e9034: Problem uploading item to the cloud is displayed.

Cause

This error may come from different sources:

a. There is a special character in the image path or in the .p4d path

Special characters such as 親, ת, ę, ž, etc.. if present in the image or the p4d path, can prevent the upload of the project.

The name cant contains more than 100 characters (cannot have slashes, must not start with a dash, and cannot end with whitespace or a dot).

b. A firewall/proxy is blocking the upload

A security network or a proxy can block communication with Pix4D servers.

c. An antivirus is blocking the upload

An antivirus software can block the communication with Pix4D servers.

d. There is an unstable Internet connection

The uploader needs to keep a stable connection with Pix4D servers during the entire upload. If the connection is weak or is lost, this error can occur.

e. The computer goes in stand-by/sleep mode

The device enters the stand-by/sleep mode and the upload is interrupted.

Solution

a. There is a special character in the image path or in the .p4d path

  1. Close the PIX4Dmapper project.
  2. Remove the special character in the path or move the file(s) to a place whose path does not contain special characters.
  3. Open again the project in PIX4Dmapper.
  4. Save the project.
  5. Reupload the project files to PIX4Dcloud.

b. A firewall/proxy is blocking the upload

Deactivate the firewall/proxy if possible or ensure the firewall/proxy allows the necessary traffic. For more information: Proxy / firewall configuration when working with PIX4Dcloud.

c. An antivirus is blocking the upload

Verify that the installed antivirus is allowing the traffic to pix4d.com through ports 80 and 443.

d. There is an unstable Internet connection

  • The recommendation is to monitor the connection and once it is stable, launch the upload again
  • Try a different Internet connection. For example do not use the Wi-fi but use an ethernet cable if possible
  • Simply try again with the upload

e. The computer goes in stand-by/sleep mode

Try again uploading the project. Do not let the computer go in standby/sleep mode as this interrupts the connection with Pix4D servers.