Create my first PIX4Dsurvey project from A to Z

Follow

This article shows how to use PIX4Dsurvey for the first time. In particular, this page will show how to get from a collection of point clouds to the creation of a Triangular Irregular Network (TIN) and Contour Lines.

 
Note: This article was created using PIX4Dsurvey version 1.39.1. A more recent version might have a slightly different appearance.

Download dataset

To follow the steps described in this guide, you need to download for free* and extract the two exercise point clouds from this link: PIX4Dsurvey_AZ_project.zip (497 MB).

Content:

  • Pix4Dsurvey_example_Rivaz_Pix4Dsurvey_Demo_group1_densified_point_cloud.las
    • Point cloud created with photogrammetry processing.
    • Coordinate System: CH1903+ / LV95 - EPSG:2056, Bessel 1841 ellipsoid
  • Pix4Dsurvey_example_Rivaz_Laser_scan_village.las
    • Point cloud collected with a laser scanner
    • Coordinate System: CH1903+ / LV95 - EPSG:2056, Bessel 1841 ellipsoid
 
Important: *These datasets may only be used for personal or professional training. For commercial or promotional use, "Courtesy of Pix4D / pix4d.com" must be displayed and all the text linked to pix4d.com. For more usage information, please contact our marketing team.

Preferences

Before starting the project right away, we advise taking a look at PIX4Dsurvey's preferences and modifying them if necessary. This might result in a better experience during all future projects.

  1. Access the preferences:
    1. Windows user: Click on the menu Edit > Preferences.
    2. MacOS users: Click on the menu PIX4Dsurvey > Preferences.
  2. In the General tab, select the Language according to your preference (this guide will use the English version). 
  3. Choose a Default folder path suitable for most of your projects. This folder will be selected by default at every new project creation. Make sure you have read/write privileges in this folder and that you have enough disk space available. If possible, avoid network drives or cloud-shared folders such as Google Drive, OneDrive, Dropbox, or other.
  4. Click Done. The preferences selected are saved and kept for a future project.

    PIX4Dsurvey preferences

    PIX4Dsurvey preferences window.

 
Tip: Additional information about preference settings in PIX4Dsurvey can be found in the Preference settings - PIX4Dsurvey article.

Log in and project creation

This section describes how to log in and how to create the actual project in PIX4Dsurvey.

To log in to PIX4Dsurvey, sign-up for a Pix4D account or use the existing Pix4D account to login to the software.

  1. Click the Pix4Dsurvey_user_icon.png icon or Log in on the top right side of the screen.
  2. Enter the Email and Password.
  3. Click Login.

Once you are logged in, there are mainly three ways to create a project in PIX4Dsurvey:

  • Drag and drop input files into the home screen.
  • From the home screen
  • From the menu bar
 
Tip: Additional information on how to create a new project in PIX4Dsurvey can be found in the Project management > New project - PIX4Dsurvey article.

For this exercise, we will use the first method: Drag and drop input files into the home screen.

  1. Make sure you extracted the PIX4Dsurvey_AZ_project.zip compressed file found in the download dataset section.
  2. Open PIX4Dsurvey.
  3. Open the PIX4Dsurvey_AZ_project folder:
    1. Windows users: Open a File explorer window and navigate to the PIX4Dsurvey_AZ_project folder.
    2. MacOS users: Open a finder window and navigate to the PIX4Dsurvey_AZ_project folder.
  4. Drag and drop the Pix4Dsurvey_example_Rivaz_Pix4Dsurvey_Demo_group1_densified_point_cloud.las file from the folder to the PIX4Dsurvey home screen.

    PIX4Dsurvey Drag and Drop

    Importing a LAS file to PIX4Dsurvey using the drag and drop method.

  5. Choose a Project name such as "My first PIX4Dsurvey project". The path will be the one chosen in the preferences section.

    PIX4Dsurvey Project name and path

    Project name and path selection prior to creating the PIX4Dsurvey project.

  6. Click on Start.
  7. PIX4Dsurvey imports the point cloud LAS file. At the end of the import, the point cloud will be displayed in PIX4Dsurvey. Note on the bottom-left side, PIX4Dsurvey detected the coordinate system of the point cloud automatically: CH1903+ / LV95 - EPSG:2056.

    PIX4Dsurvey Imported point cloud

    PIX4Dsurvey project containing the imported point cloud and automatically detected CRS.

 
Tip: The Coordinate Reference System (CRS) is detected automatically by PIX4Dsurvey based on the information written in the point cloud metadata. Additional information about coordinate systems in PIX4Dsurvey can be found in the How to use coordinate systems in PIX4Dsurvey article.

Add a second point cloud (optional)

PIX4Dsurvey can import and handle more than one point cloud in a single project if necessary. If the added point clouds are in a different CRS, PIX4Dsurvey will proceed with a transformation. In this exercise, the newly added point cloud has the same CRS as the PIX4Dsurvey project created in the previous step.

  1. If not already open after the last exercise, open the "My first PIX4Dsurvey project" project.
  2. Drag and drop the Pix4Dsurvey_example_Rivaz_Laser_scan_village.las file over the open project.
  3. As the newly imported point cloud has the same CRS as the project, no popup appears, and the new point cloud is directly imported and displayed.
 
Tip: Additional information on how to import point clouds in PIX4Dsurvey can be found in the Project management > Import point clouds - PIX4Dsurvey article.

Once both point clouds are loaded into the "My first PIX4Dsurvey project" project, it is possible to turn the visualization on and off for single point clouds or projects.

  1. Navigate to an area in the project where both point clouds are visible.
    PIX4Dsurvey both Point clouds


    Area in the village where the laser scan point cloud is located.

    1. Left-click to pan the 3D view.
    2. Right-click to rotate the 3D view.
    3. Use the scroll wheel to zoom in and out on the 3D view.
  2. Locate the Point clouds tab in the Content sidebar on the left side of the PIX4Dsurvey window.
    PIX4Dsurvey Point Cloud Tab


    Point clouds tab in the Content sidebar

  3. (optional) If not already expanded, click on the expand button Expand icon to show both point clouds.
  4. Click on the Hide all point clouds button Hide icon in the Point clouds tab. Both point clouds will disappear from the 3D view.
  5. Click on the Show all point clouds button Show icon. Both point clouds are displayed again in the 3D view.
  6. Hovering with the mouse over the two point cloud names in the Point clouds tab will show the Hide points button Hide icon. Click on this button to hide or show a single point cloud.
    Hide and show point cloud


    Hide and show the two different point clouds.

  7. Show both point clouds again.
  8. Press the key "7" on your keyboard to display the entire project from the top.
  9. Save the project:
    1. Windows user: Click on the menu File > Save.
    2. MacOS users: Click on the menu PIX4Dsurvey > Save.
 
Tip: Save your project after each modification.
  • Windows user: Click on the menu File > Save or the shortcut Ctrl + s.
  • MacOS users: Click on the menu PIX4Dsurvey > Save or the shortcut ⌘ + s.

A non-saved project will show an asterisk after the filename. The asterisk will disappear once the project is saved.

PIX4Dsurvey non saved project

Filename of a non-saved project, showing the asterisk * at the end of the filename.

 
Tip: Additional information on how to navigate in the 3D view in PIX4Dsurvey can be found in the Navigation > Navigate in the 3D view - PIX4Dsurvey article.
 
Tip: Hiding or showing specific point clouds instead of all the imported point clouds is helpful when focusing on a specific region in the project.

Project settings

Project settings are settings that are applied to the entire project and not to a specific point cloud, layer or vector.

  1. Open the Project settings by clicking on the Project settings icon PIX4Dsurvey project settings, located in the top-right corner of the PIX4Dsurvey window.
  2. Modify the Point Size PIX4Dsurvey point size using the slider. You can see how the point size is changing for both point clouds. Restore the original size.
  3. (optional) To modify the size of a single point cloud, go to the Point clouds tab in the Content sidebar on the left and hover over the names of both point clouds. Click on the Gear icon PIX4Dsurvey point cloud properties to enable the point cloud options. A slider will appear where it is possible to change the point size for that specific point cloud. The Point size slider will overwrite changes in the point cloud options.
  4. Another helpful setting in the Project setting is the Color by elevation PIX4Dsurvey color by elevation. This can be helpful in identifying changes in elevation in the profile. Turn on the toggle Toggle on and eventually choose a preferred color scale. All the points will be assigned to a color depending on their elevation.
    PIX4Dsurvey color by elevation


    Color by elevation tool applied to all the points of the project.

  5. Turn off the slider Toggle off .
 
Tip: Additional information about the project settings (image) in PIX4Dsurvey can be found in the Navigation > Project Settings - PIX4Dsurvey article.

Create bookmarks

Bookmarks allow saving a particular 3D location and camera orientation of the current view. This feature can be useful in many contexts when there is a need for a later revisit or to show particular areas. We will use this feature to inspect the result of the processing leading to a TIN and contour lines.

  1. Open the Bookmarks tab bookmarks tab in the status center using the expand button Expand.png.
  2. Bookmark of the village:
    1. Navigate into the main square, making sure that both roads and buildings are visible.
    2. Click on PIX4Dsurvey bookmark current view.
    3. Click on the "Camera bookmark 1" text in the newly created bookmark and rename it to Bookmark village. Press Enter on the keyboard.
      PIX4Dsurvey bookmark village


      Location in the status bar of the first created bookmark.

  3. Bookmark of the vineyard
    1. Navigate to a vineyard and move the 3D view so that you can clearly see the plants
    2. Click on PIX4Dsurvey bookmark current view.
    3. Click on the "Camera bookmark 1" text in the newly created bookmark and rename it to Bookmark vineyard. Press Enter on the keyboard.
  4. Bookmark of the main road
    1. Navigate to the main road and move the 3D view so that you can clearly see the parking near the bridge.
    2. Click on PIX4Dsurvey bookmark current view.
    3. Click on the "Camera bookmark 1" text in the newly created bookmark and rename it to Bookmark main road. Press Enter on the keyboard.
  5. Continue navigating in the 3D view. You will notice that a purple camera was created in the 3D position of the view for every bookmark.
    PIX4Dsurvey bookmark camera in the 3D view


    Location of the three created bookmarks in the status bar and the camera in the 3D view showing the virtual camera location for a bookmark.

  6. Click on PIX4Dsurvey bookmark visit button to move the view to the one assigned when each bookmark was created.
    PIX4Dsurvey Bookmarks navigate video


    Rotation between the three bookmarks using the Visit button.

  7. Collapse the Bookmarks tab using the collapse button collapse icon.
  8. Save the project with Ctrl + s (Windows) or ⌘ + s (macOS).
 
Tip: Additional information about the Bookmarks in PIX4Dsurvey can be found in the Bookmarks - PIX4Dsurvey article.

Distant outlier filter

The Distant outlier filter detects points that are isolated from the main scene in all point clouds and recycles them.

The removed points are not used in further steps, such as the terrain classification.

  1. Open the Processes sidebar:
    1. Click Process PIX4Dsurvey processing icon and expand Expand icon the Distant outlier filter PIX4Dsurvey distant outlier iconor,
    2. On the Menu bar, click Process > Distant outlier filter.
     
    Tip: For simplicity, only the first method for accessing specific processing will be described. However, all processes can be accessed also using the Process menu.
  2. Click on PIX4Dsurvey distant outliers iconDetect and delete outliers.
  3. About 15 points are deleted from the point cloud. You can read this information in the status center. You can learn more about the status center in PIX4Dsurvey in this article: Status center - PIX4Dsurvey.
  4. It is possible to undo the action
    1. Go to menu Edit > Undo filter outliers or
    2. Press Ctrl + z (windows) or ⌘ + z (macOS)
  5. Run the distant outlier filter again or redo the action using the Ctrl + y (windows) or ⌘ + z (macOS) combination or in the menu Edit > Redo filter outliers.
 
Note: The Distant Outlier Filter focuses on finding points that are isolated and far away from the point cloud. Therefore, it cannot be used to filter out noise in the main body of the point cloud.
 
Tip: Additional information about the Distant outlier filter in PIX4Dsurvey can be found in the Distant outlier filter - PIX4Dsurvey article.

Terrain filter

The Terrain filter process classifies selected input point clouds into terrain and non-terrain based on the selected processing values. These classes will then be used in future processing steps, for example, to create a grid of points only from the terrain class.

  1. Click Process PIX4Dsurvey processing icon and expand Expand icon the Terrain filter Pix4Dsurvey terrain filter.
  2. Make sure that both point clouds are selected as Input point cloud
    PIX4Dsurvey input point clouds for the terrain filter


    Point clouds used as input for the Terrain filter.

  3. Click on Pix4Dsurvey terrain filter icon Filter terrain

The point cloud in the project has turned into two colors: Green for points belonging to the Terrain group and purple for points belonging to the Non-terrain group. It is possible to re-enable the RGB values for one or both groups by hovering over the Terrain or Non-terrain classes in the Content sidebar on the left and click the Show class in RGB PIX4Dsurvey RGB icon button. To show the class color again, click on Show class in monochrome PIX4Dsurvey Monochrome icon.

PIX4Dsurvey classes

Show class in RGB button in the Classes tab.

Now it is possible to use the bookmarks created previously to assess the quality of the classification.

  1. Open the Bookmarks tab bookmarks tab in the status center using the expand button Expand.png.
  2. Click PIX4Dsurvey bookmark visit icon on every different bookmark. The 3D view will change and will show the same areas saved in the previous chapter.
  3. Visit the Bookmark vineyard and take a look at the classification.
  4. In the Terrain filter processing panel, change the Above ground threshold (m) to 1m.
  5. Run the Terrain filter again.
  6. Verify how the change in the Above ground threshold (m) changed the result.
  7. Visit the other bookmarks to see the effects in changing the Above ground threshold (m) value.
  8. Change the Above ground threshold (m) back to 0.5m and run the Terrain filter again.
PIX4Dsurvey terrain filter 1m


Resulting classes after the Terrain filter run with the Above ground threshold (m) set to 1m. Green is the terrain, blue is the non-terrain.

PIX4Dsurvey terrain filter 05m


Resulting classes after the Terrain filter run with the Above ground threshold (m) set to 0.5m. Green is the terrain, violet is the non-terrain.

 
Tip: Additional information about the Terrain filter in PIX4Dsurvey can be found in the Terrain filter - PIX4Dsurvey article.

Vectorize terrain

Not all the points of the grid of points fall on breaklines. This can create inaccuracies in the TIN (Triangular Irregular Network). To improve the quality of the TIN, it is suggested to create polylines at breaklines,

  1. Click PIX4Dsurvey bookmark visit button on the Bookmark main road to move the 3D view to this bookmark. 
  2. Enable the RGB view for the point cloud classes using the PIX4Dsurvey RGB icon button in the classes tab of the Content sidebar.
  3. Select the Polyline PIX4Dsurvey Polyline icon tool.
    PIX4Dsurvey polyline tool


    Location of the Polyline tool in the toolbar-

  4. Vectorize the polyline using the left mouse button along the border of the parking.
    Polyline drawn at the border of the parking


    Polyline created at the border of the parking.

  5. The polyline is found in the Layers tab of the Content sidebar. Click on the gear icon PIX4Dsurvey gear icon and ensure that the Terrain Layer is enabled Toggle on icon.
    PIX4Dsurvey layers tab


    -The Layers tab located in the Content sidebar. Ensure that the Layer containing the polyline created in the previous step has the Terrain Layer enabled.

 
Tip: Additional information about vectorization in PIX4Dsurvey can be found in the Vectorization - PIX4Dsurvey article.

Grid of points

The Grid of points tool helps to automate the creation of spot elevations and allows for drastic simplification of the number of point cloud points. No new points are created; only existing points from the input data are used. It is possible to use the filter in order to take into account only points from a specific point cloud, from a specific class, or a combination of both choices.

  1. Click Process PIX4Dsurvey processing icon and expand Expand icon the Grid of points PIX4Dsurvey Grid of points icon.
  2. Make sure both point clouds are selected in the Input point cloud and that only the Terrain class is selected in the filter.
    PIX4Dsurvey grid of points settings


    Grid of points settings.

  3. Keep the Regular grid type selected. Visit the Grid of points - PIX4Dsurvey article to learn more about the other grid types. Keep the Grid spacing (m) 2.5.
  4. Click on PIX4Dsurvey Grid of points icon Make grid.

This will create a grid of points with 2.5m spacing based on the Terrain points in both input point clouds. The grid of points are located in the TIN tab in the Content sidebar.

PIX4Dsurvey grid of points in content sidebar

TIN tab in the Content sidebar. The Grid of points are located in this tab.

 
Tip: Additional information about the Grid of points in PIX4Dsurvey can be found in the Grid of points - PIX4Dsurvey article.

TIN

The TIN process creates a seamless set of triangles representing a surface.

  1. Click Process PIX4Dsurvey processing icon and expand Polygon_2x.png the TIN PIX4Dsurvey TIN icon.
  2. Make sure the grid of points created previously is selected as input.
  3. Disable Use terrain layer as breaklines Toggle off icon.
  4. Click on PIX4Dsurvey TIN icon Generate TIN.

Only the points of the grid are considered for the creation of the TIN, therefore the border of the parking is not well modeled. Disable all the point clouds with the Hide all point cloudsHide all point clouds icon icon in the Content sidebar for better visibility of the TIN.

PIX4Dsurvey point clouds hide all layers button

Location of the Hide all layers button in the Point clouds tab of the Content sidebar.

PIX4Dsurvey TIN use terrain layer as breaklines disabled

TIN created keeping the Use terrain layer as breaklines disabled.

  1. If needed, click Process PIX4Dsurvey processing icon and expand Polygon_2x.png the TIN PIX4Dsurvey TIN icon.
  2. Enable Use terrain layer as breaklines Toggle on icon.
  3. Click on PIX4Dsurvey TIN icon Generate TIN.

Now both the points of the grid and the terrain polygon were taken into account and the TIN reflects reality better.

PIX4Dsurvey TIN use terrain layer as breaklines enabled

TIN created keeping the Use terrain layer as breaklines enabled. Note how the TIN is now following the polyline created as breakline.

 
Tip: Additional information about the TIN in PIX4Dsurvey can be found in the TIN - PIX4Dsurvey article.

Contour lines

PIX4Dsurvey creates contour lines based on the TIN.

  1. Click Process PIX4Dsurvey processing icon and expand Expand icon the Contour lines PIX4Dsurvey Contour lines icon.
  2. Keep Interval (m) 1.
  3. Enable Discard contour lines loops shorter than (m) Toggle ON. Keep the suggested value 10.
  4. Click on PIX4Dsurvey Contour lines icon Generate contour lines

The contour lines are located in the TIN tab in the Content tab.

PIX4Dsurvey Contour Lines content sidebar

TIN tab in the Content sidebar. The Contour lines are located in this tab..

Tip: Additional information about the contour lines in PIX4Dsurvey can be found in the Contour lines - PIX4Dsurvey article.

Export

Once you are satisfied with the results, you can export one or more files generated.

  1. Open the Export PIX4Dsurvey export icontab.
  2. in the Point cloud section, enable both point clouds and remove the Non-terrain label. Only points from the terrain class will be exported.
  3. Uncheck Vector layers and Grid of points.
  4. Select TIN (LandXML format) and Contour lines (in SHP format). 
  5. Click Export.
  6. Click on Open destination folder.

All the files we selected to export are found in that folder. 

 
Tip: Use a custom suffix and/or select Checkbox.png Add timestamp in case you are generating the same output again, and you don't want to overwrite the older exported files.
 
Tip: Additional information about export in PIX4Dsurvey can be found in the Export - PIX4Dsurvey article.
Was this article helpful?
3 out of 3 found this helpful

Article feedback (for troubleshooting, post here instead)

0 comments

Article is closed for comments.