Example projects

Need a dataset to try Pix4D software? Download* any of these projects (some of them even include ground control points) and process them with Pix4D software to get your first experience. For more inspiration and examples feel free to have a look at the Hall of Fame in the community.

* The usage of these datasets is meant to be for personal and professional training. If you would like to use them for commercial or promotional objectives, please ensure to mention "Courtesy of Pix4D / pix4d.com" linking all this text to pix4d.com.

   

Pix4Dmapper

Quarry

The goal of this project is to generate a DSM and an Orthomosaic of a quarry using a Canon IXUS 220HS.
quarry_raster_dsm.png
General project information
Project
Location Switzerland
Average Ground Sampling Distance (GSD) 8.78 cm / 3.46 in
Area covered 0.5776 km2 / 57.7565 ha / 0.223 sq. mi. / 142.79 acres
Output coordinate system WGS84 / UTM zone 32N
Vertical Coordinate System: Geoid Height Above WGS 84 Ellipsoid = 0 meters
Image acquisition
UAV swinglet CAM (senseFly)
Image acquisition plan 1 flight, grid flight plan
Camera Canon IXUS 220HS (RGB)
Images
Number of images 127
Image size 4000x3000
Image geolocation coordinate system WGS84
GCPs
Number of GCPs 7 3D GCPs
GCPs coordinate system WGS84
Download project files

The dataset can be downloaded here and can be found processed on Pix4D Cloud here

The downloaded folder contains the following files and folders: 

  • imagesRGB images in JPG format
  • inputs/gcp_overview: images that help to identify each GCPs
  • inputs/gcpPositionsLatLongAlt.csv: GCP input geolocation file.
  • example_quarry.p4dproject file that can be opened in Pix4Dmapper.
Instructions
Process the dataset using the included .p4d project file

This section describes how to process the dataset in order to generate the DSM and the Orthomosaic of a quarry.

1. Open the project example_quarry.p4d
2. On the menu bar, click View > Processing. The Processing bar opens at the bottom of the main window.  

 
Note: As the goal of this project is to generate the DSM and the Orthomosaic, and as it has been taken using aerial nadir images, the template used for the Processing has been set to 3D Maps. This can be seen in Process > Processing Options....

 3. On the Processing bar, click Start to start the processing.

Process the dataset creating a new project

This section describes how to create and process a project in order to generate the DSM and the Orthomosaic of a quarry.

A) Create a new project:

1. Start Pix4Dmapper.
2. On the Menu bar, click Project > New Project....
3. The New Project wizard opens.
4. In Name: Type a name for the project. In this example type example_quarry.
5. (optional) In Create In: click Browse..., and in the Select Project Location pop-up, navigate to select the folder where the project and results will be stored and click Select Folder

 
Note: When the project is created, a folder named after the project name typed in the Name field will be created in the selected folder and will store all the results. The .p4d project file will also be stored in this folder.

6. (optional) Select the check box Use As Default Project Location to save all new projects in the selected folder.
7. In the section Project Type, keep selected the default option New Project.
8. Click Next.

The New Project wizard displays the Select Images window.

9. Click Add Directories... and select the images folder to add the images to the project.
10. Click Next.

The New Project wizard displays the Image Properties window. The image geolocation is automatically loaded from the image EXIF data and is given in WGS84 (latitude, longitude, altitude) coordinates with vertical coordinate system given by a Geoid Height Above WGS 84 Ellipsoid of 0 meters. The camera model is loaded from the camera model database (CanonIXUS220HS_4.3_4000x3000 (RGB)).

11. Click Next.

The New Project wizard displays the Select Output Coordinate System window. By default the last output coordinate system selected in the software is selected.

12. Select Auto Detected.
13. Select Advanced Coordinate Options and under Vertical Coordinate System select Geoid Height Above WGS 84 Ellipsoid. Set the value to 0.
14. Click Next.

The New Project wizard displays the Processing Options Template window.

15. Click 3D Maps to select the template.

 
Note: As the goal of this project is to generate the DSM and the Orthomosaic, and as it has been taken using aerial nadir images, the template to be selected is the 3D Maps.

16. Click Finish to finish the wizard and create the project. The Processing bar opens at the bottom of the main window.

 

B) Introduce and mark the GCPs:

1. On the Menu bar, click Project > GCP/MTP Manager....

The GCP/MTP Manager window opens. Change the GCP Coordinate System to WGS 84 with a vertical coordinate system given by a Geoid Height Above WGS 84 Ellipsoid of 0 meters.

2. On the GCP Coordinate System section, click Edit....
3. On the Select GCP Coordinate System window, set the Unit to m.
4. On the Select GCP Coordinate System window, select Known Coordinate System [m], type WGS 84 and select it in the drop-down list.
5. On the Select GCP Coordinate System window, select Advanced Coordinate Options and under Vertical Coordinate System select MSL egm96.
6. On the Select GCP Coordinate System window, click OK.
7. On the GCP/MTP Manager window, on the GCP/MTP Table, click Import GCPs....
8. On the Import Ground Control Points window, under Coordinates Order, select Latitude, Longitude, Altitude option. 
9. On the Import Ground Control Points windows, click Browse, select the GCP file gcpPositionsLatLongAlt.csv from the inputs folder and click OK.
10. On the Import Ground Control Points windows, click OK.

The GCPs and their coordinates are imported and can be visualized in the GCP/MTP Manager window.

11. On the GCP/MTP Manager window click OK.
12. On the Processing bar select 1. Initial Processing, deselect 2. Point Cloud and Mesh and 3. DSM, Orthomosaic and Index.
13. On the Processing bar, click Start to start the processing.

When step 1. Initial Processing is finished the rayCloud opens.

14. Mark the GCPs using the rayCloud following instructions 2. to 11. as described here 360000276046. The images in the folder inputs/gcp_overview help to identify the GCPs should be marked.

 

C) Generate the DSM and Orthomosaic

When the GCPs are marked and the project is re-optimized.

1. On the Processing bar, deactivate 1. Initial Processing and activate 2. Point Cloud and Mesh and 3. DSM, Orthomosaic and Index.
2. On the Processing bar, click Start to start the processing. 

Cadastre

The goal of this project is to generate the DSM and the Orthomosaic of a village using a Canon IXUS 120IS.
cadastre_point_cloud.png
General project information
Project
Location Switzerland
Average Ground Sampling Distance (GSD) 5.1 cm / 2 in
Area covered 0.2128 km2 / 21.2822 ha / 0.0822 sq. mi. / 52.6167 acres
Output coordinate system WGS84 / UTM zone 32N
Vertical Coordinate System: Geoid Height Above WGS 84 Ellipsoid = 0 meters
Image acquisition
UAV swinglet CAM (senseFly)
Image acquisition plan 1 flight, grid flight plan
Camera Canon IXUS 120IS (RGB)
Images
Number of images 68
Image size 4000x3000
Image geolocation coordinate system WGS84
GCPs
Number of GCPs None
GCPs coordinate system None
Download project files

The dataset can be downloaded here and can be found processed on Pix4D Cloud here

The downloaded folder contains the following files and folders: 

  • imagesRGB images in JPG format
  • example_cadastre.p4dproject file that can be opened in Pix4Dmapper.
Instructions
Process the dataset using the included .p4d project file

This section describes how to process the dataset in order to generate the DSM and the Orthomosaic of a village.

1. Open the project example_cadastre.p4d
2. On the Menu bar, click View > Processing. The Processing bar opens at the bottom of the main window.

 
Note: As the goal of this project is to generate the DSM and the Orthomosaic, and as it has been taken using aerial nadir images, the template used for the processing has been set to 3D Maps. This can be seen in Process > Processing Options....

3. On the Processing bar, click Start to start the processing.

Process the dataset creating a new project

This section describes how to create and process a project in order to generate the DSM and the Orthomosaic of a village.

A) Create a new project:

1. Start Pix4Dmapper.
2. On the Menu bar, click Project > New Project....
3. The New Project wizard opens.
4. In Name: Type a name for the project. In this example type example_cadastre.
5. (optional) In Create In: Click Browse, and in the Select Project Location pop-up, navigate to select the folder where the project and results will be stored and click Select Folder.

 
Note: When the project is created, a folder named after the project name typed in the Name field will be created in the selected folder and will store all the results. The .p4d project file will also be stored in this folder.

6. (optional) Select the check box Use As Default Project Location to save all new projects in the selected folder.
7. In the section Project Type, keep selected the default option New Project.
8. Click Next.

The New Project wizard displays the Select Images window.

9. Click Add Directories... and select the images folder to add the images to the project.
10. Click Next.

The New Project wizard displays the Image Properties window.  The image geolocation is automatically loaded from the image EXIF data. The coordinate system is automatically set to WGS84 with vertical coordinate system given in MSL egm96. As the image geolocation is given in WGS 84 with vertical coordinates system in Geoid Height Above WGS 84 Ellipsoid = 0, the coordinate system has to be changed.

11. On the Image Geolocation > Coodinate System click Edit...
12. On the Select Image Coordinate System window, select Known Coordinate System with coordinate system WGS 84.
13. On the Select Image Coordinate System window, select Advanced Coordinate Options, and under Vertical Coordinate System select Geoid Height Above WGS 84 Ellipsoid. Set the value to 0.
14. On the Select Image Coordinate System window, click OK

In the Image Properties window, the camera model is loaded from the camera model database (CanonDIGITALIXUS120IS_5.0_4000x3000 (RGB)).

15. Click Next.

The New Project wizard displays the Select Output Coordinate System window. By default the last output coordinate system selected in the software is selected.

16. Select Auto Detected.
17. Select Advanced Coordinate Options and under Vertical Coordinate System select Geoid Height Above WGS 84 Ellipsoid. Set the value to 0.
18. Click Next

The New Project wizard displays the Processing Options Template window. 

19. Click 3D Maps to select the template.

 
Note: As the goal of this project is to generate the DSM and the Orthomosaic, and as it has been taken using aerial nadir images, the template to be selected is the 3D Maps template.  

20. Click Finish to finish the wizard and create the project. The Processing window opens at the bottom of the main window.

B) Process the project:

1. On the Processing bar, click Start to start the processing.

Forensic

The goal of this project is to generate the Point Cloud and the 3D Textured Mesh of a forensic scene.
forensic_point_cloud.png
General project information
Project
Location USA
Average Ground Sampling Distance (GSD) 0.24 cm / 0.09 in
Output coordinate system WGS84 / UTM zone 17N
Image acquisition
UAV DJI Phantom 3 Advanced
Image acquisition plan 1 flight, circular flight around the scene
Camera FC300 X (RGB)
Images
Number of images 69
Image size 4000x3000
Image geolocation coordinate system WGS84 
GCPs
Number of GCPs None
GCPs coordinate system None
Download project files

The dataset can be downloaded here.

The downloaded folder contains the following files and folders: 

  • images: RGB images in JPG format.
  • example_forensic.p4d: project file that can be opened in Pix4Dmapper.
Instructions
Process the dataset using the included .p4d project file

This section describes how to process the dataset in order to generate the 3D model of a building.

1. Open the project example_forensic.p4d by double clicking it. 
2. On the Menu bar, click View > Processing. The Processing bar opens at the bottom of the main window.

 
Note: As the goal of this project is to generate the point cloud the 3D model (no DSM and orthomosaic) and as it has been taken using oblique images the template used for the processing has been set to 3D Models. This can be seen in Process > Processing Options... .

 3. On the Processing bar, click Start to start the processing.

Process the dataset creating a new project

This section describes how to create and process a project in order to generate a 3D model of a building.

A) Create a new project:

1. Start Pix4Dmapper.
2. On the Menu bar, click Project > New Project....
3. The New Project wizard opens.
4. In Name: Type a name for the project. In this example type example_building.
5. (optional) In Create In: click Browse..., and in the Select Project Location pop-up, navigate to select the folder where the project and results will be stored and click Select Folder.

 
Note: When the project is created, a folder named after the project name typed in the Name field will be created in the selected folder and will store all the results. The .p4d project file will also be stored in this folder.

6. (optional) Select the check box Use As Default Project Location to save all new projects in the selected folder.
7. In the section Project Type, keep selected the default option New Project.
8. Click Next.

The New Project wizard displays the Select Images window.

9. Click Add Directories... and select the images folder to add the images to the project.
10. Click Next.

The New Project wizard displays the Image Properties window. The image geolocation is automatically loaded from the image EXIF data and is given in WGS84 (latitude, longitude, altitude) coordinates with vertical coordinate system given at Geoid Above Ellipsoid=0 m. The camera model is loaded from the camera model database (FC300X_3.6_4000x3000 (RGB)).

11.Click Next.

The New Project wizard displays the Select Output Coordinate System window. By default the last output coordinate system selected in the software is selected.

12. Under Unit, select m
13. Select Auto Detected.
14. Select Advanced Coordinate Options and under Vertical Coordinate System select Geoid Above Ellipsoid=0.

The New Project wizard displays the Processing Options Template window. 

 
Note: As the goal of this project is to generate the point cloud and the 3D model (no DSM and orthomosaic), and as it has been taken using oblique images, the template to be select is the 3D Models template.

15. Select the 3D Models template.
16. Click Finish to finish the wizard and create the project. The Processing bar opens at the bottom of the main window.

B) Process the project:

1. On the Processing bar, click Start to start the processing.

 

Pix4Dfields

Rostock Sequoia multispectral

The goal of this project is to get an NDVI index map of a field using the Sequoia camera that captures Green, Red, Red edge and NIR wavelengths.
fields_msp.png
General project information
Project
Location Germany
Average Ground Sampling Distance (GSD) 10.0 cm / 3.94 in
Area covered 0.449 km2 / 44.9 ha / 0.173 sq. mi. / 110.95 acres
Output coordinate system WGS84 / local Transverse Mercator
Image acquisition
UAV eBee (senseFly)
Image acquisition plan 1 flight, grid flight plan, 106 meters flight height
Camera Sequoia (Green, Red, Red edge, NIR)
Images
Number of images 1804
Image size 1280x960
Image geolocation coordinate system WGS84
Download project files

The dataset can be downloaded here.

The downloaded folder contains the following files and folders:

  • Images: Red, Green, Red edge and NIR images in TIFF format.
  • Boundary: project file that can be opened in Pix4Dfields.

Start a new project in Pix4Dfields

To begin processing the dataset, follow the guide A project step-by-step.

Rostock S.O.D.A. RGB camera

The goal of this project is to get an NDVI index map of a field using the S.O.D.A camera that captures Red, Green, Blue wavelengths.
fields_rgb.png
General project information
Project
Location Germany
Average Ground Sampling Distance (GSD) 2.80 cm / 1.10 in
Area covered 0.483 km2 / 48.3 ha / 0.186 sq. mi. / 119.35 acres
Output coordinate system WGS84 / local Transverse Mercator
Image acquisition
UAV eBee (senseFly)
Image acquisition plan 1 flight, grid flight plan, 119 meters flight height
Camera S.O.D.A. (Red, Green, Blue)
Images
Number of images 374
Image size 5472x3648
Image geolocation coordinate system WGS84
Download project files

The dataset can be downloaded here.

The downloaded folder contains the following files and folders:

  • Images: Red, Green, Blue images in JPG format.
  • Boundary: project file that can be opened in Pix4Dfields.

Start a new project in Pix4Dfields

To begin processing the dataset, follow the guide A project step-by-step.

 

Pix4Dmodel

Building - DJI

The goal of this project is to generate the 3D model of a building taken by an AscTec Falcon 8 UAV.
Building_DJI.png
General project information
Project
Location Germany
Average Ground Sampling Distance (GSD) 1.89 cm / 0.7 in
Area covered Undefined
Output coordinate system WGS84 / UTM zone 32N
Vertical Coordinate System: MSL egm96
Image acquisition
UAV AscTec Falcon 8 UAV (Ascending Technologies)
Image acquisition plan 1 flight, circular flight around the building
Camera Sony NEX-5 (RGB)
Images
Number of images 36
Image size 4592x3056
Image geolocation coordinate system WGS84
GCPs
Number of GCPs None
GCPs coordinate system None
Download project files

The dataset can be downloaded here and can be found processed on Pix4D Cloud here

The downloaded folder contains the following files and folders: 

  • images: RGB images in JPG format.
  • example_building.p4d: project file that can be opened in Pix4Dmapper.
Instructions
Process the dataset using the included .p4d project file

To process the dataset in order to generate the 3D model of a building:

1. Open the project example_building.p4d by double clicking it. 
2. On the Menu bar, click View > Processing. The Processing bar opens at the bottom of the main window.

 
Note: As the goal of this project is to generate only the 3D model (no DSM and orthomosaic), the template used for the processing has been set to 3D Models. This can be seen in Process > Processing Options... .

 3. On the Processing bar, click Start to start the processing.

Process the dataset creating a new project

This section describes how to create and process a project in order to generate a 3D model of a building.

A) Create a new project:

1. Start Pix4Dmapper.
2. On the Menu bar, click Project > New Project....
3. The New Project wizard opens.
4. In Name: Type a name for the project. In this example type example_building.
5. (optional) In Create In: click Browse..., and in the Select Project Location pop-up, navigate to select the folder where the project and results will be stored and click Select Folder.

 
Note: When the project is created, a folder named after the project name typed in the Name field will be created in the selected folder and will store all the results. The .p4d project file will also be stored in this folder.

6. (optional) Select the check box Use As Default Project Location to save all new projects in the selected folder.
7. In the section Project Type, keep selected the default option New Project.
8. Click Next.

The New Project wizard displays the Select Images window.

9. Click Add Directories... and select the images folder to add the images to the project.
10. Click Next.

The New Project wizard displays the Image Properties window. The image geolocation is automatically loaded from the image EXIF data and is given in WGS84 (latitude, longitude, altitude) coordinates with vertical coordinate system given by MSL egm96. The camera model is loaded from the camera model database (NEX-5_E16mmF2.8_16.0_4592x3056 (RGB)).

11.Click Next.

The New Project wizard displays the Select Output Coordinate System window. By default the last output coordinate system selected in the software is selected.

12. Under Unit, select m
13. Select Auto Detected.
14. Select Advanced Coordinate Options and under Vertical Coordinate System select MSL > egm96.

The New Project wizard displays the Processing Options Template window. 

 
Note: As the goal of this project is to generate only the 3D model (no DSM and orthomosaic), and as it has been taken using terrestrial images, the template to be select is the 3D Models template.

15. Select the 3D Models template.
16. Click Finish to finish the wizard and create the project. The Processing bar opens at the bottom of the main window.

B) Process the project:

1. On the Processing bar, click Start to start the processing.

 

Eagle statue - Handheld camera

The goal of this project is to generate the 3D model of the statue of an eagle by taking images from the ground using a Canon EOS 7D with perspective lens.
eagle_statue_mesh.png
General project information
Project
Location Switzerland
Average Ground Sampling Distance (GSD) Undefined
Area covered Undefined
Output coordinate system Arbitrary
Image acquisition
UAV None
Image acquisition plan 2 walks around the statue, each at a different altitude
Camera Canon EOS 7D (RGB)
Images
Number of images 44
Image size 5184x3456
Image geolocation coordinate system None
GCPs
Number of GCPs None
GCPs coordinate system None
Download project files

The dataset can be downloaded here.

The downloaded folder contains the following files and folders: 

  • images: RGB images in JPG format.
  • example_eagle.p4dproject file that can be opened in Pix4Dmapper.
Instructions
Process the dataset using the included .p4d project file

This section describes how to process the dataset in order to generate the 3D model of the statue of an eagle.

1. Open the project example_eagle.p4d by double clicking it. 
2. On the Menu bar, click View > Processing. The Processing bar opens at the bottom of the main window.  

 
Note: As the goal of this project is to generate only the 3D model (no DSM and Orthomosaic), and as it has been taken using terrestrial images, the template used for the Processing has been set to 3D Models. This can be seen in Process > Processing Options...  

3. On the Processing bar, click Start to start the processing.

Process the dataset creating a new project

This section describes how to create and process a project in order to generate the 3D model of the statue of an eagle.

A) Create a new project:

1. Start Pix4Dmapper.
2. On the menu bar, click Project > New Project....
3. The New Project wizard opens.
4. In Name: Type a name for the project. In this example type example_eagle.
5. (optional) In Create In: Click on Browse, and on the Select Project Location pop-up, navigate to select the folder where the project and results will be stored and click Select Folder.  

 
Note: When the project is created, a folder named after the project name typed in the Name field will be created in the selected folder and will store all the results. The .p4d project file will also be stored in this folder.

6. (optional) Select the check box Use As Default Project Location to save all new projects in the selected folder.
7. In the section Project Type, keep selected the default option New Project.
8. Click Next.

The New Project wizard displays the Select Images window.

9. Click Add Directories... and select the images folder to add the images to the project.
10. Click Next.

The New Project wizard displays the Image Properties window. No image geolocation is detected. The camera model is loaded from the camera model database (CanonEOS7D_EF-S15-85mmf/3.5-5.6ISUSM_15.0_5184x3456 (RGB)).

11. Click Next.

The New Project wizard displays the Select Output Coordinate System window. By default the last output coordinate system selected in the software is selected.

12. Select Arbitrary Coordinate System with Unit meters.
13. Click Next.

The New Project wizard displays the Processing Options Template window.

 
Note: As the goal of this project is to generate only the 3D model (no DSM and orthomosaic), and as it has been taken using terrestrial images, the template to be selected is the 3D Models.

14. Select the 3D Models template.
15. Click Finish to finish the wizard and create the project. The Processing bar opens at the bottom of the main window.

B) Process the project:

1. On the Processing bar, select 1. Initial Processing, and deselect 2. Point Cloud and Mesh.
2. On the Processing bar, click Start to start the processing.

When Initial Processing finishes, the rayCloud opens.

3. Use the rayCloud to define a Processing Area to remove noisy points from the background and to keep only points of the statue. For more information about how to draw a Processing Area with the rayCloud: 202560179.

 
Note: The Processing Area used:

4. Edit the Processing Area such that the height adjusts to the height of the statue. For more information about how to edit a Processing Area with the rayCloud: 202560599.

 
Note: In the above Processing Area, the Maximum and Minimum Altitude are set to 50.00 [m] and -100.00 [m] respectively.

5. On the Processing bar, deselect 1. Initial Processing, and select 2. Point Cloud and Mesh.
6. On the Processing bar, click Start to start processing.

 

Office building - DJI

The goal of this project is to get a 3D model of buildings using a DJI Phantom 4 and acquiring the images with Pix4Dcapture.
DJI_office_building_cover.png
General project information
Project
Location Switzerland
Average Ground Sampling Distance (GSD) 1.67 cm / 0.65 in
Output coordinate system WGS84 / UTM zone 32N
Vertical Coordinate System: MSL egm96
Image acquisition
UAV DJI Phantom 4
Image acquisition software Pix4Dcapture
Image acquisition plan Circular mission, 4° angle between images, 30m above ground.
Camera Phantom Vision FC330
Images
Number of images 85
Image size 4000x3000
Image geolocation coordinate system WGS84
Download project files

The dataset can be downloaded here and can be found processed on Pix4D Cloud here

The downloaded folder contains the following files and folders: 

  • imagesRGB images in JPG format. The image's resolution is half the original image resolution.
  • dji_demo.p4dproject file that can be opened in Pix4Dmapper.
Instructions

This section describes how to process the dataset using the included .p4d project file in order to generate a 3D mesh of buildings.

1. Open the project dji_demo.p4d
2. On the menu bar, click View > Processing. The Processing window opens at the bottom of the main window.
3. On the Processing window, click Start to start the processing.

 
Note: As the goal of this project is to get a 3D Model, the template used for the processing has been set to 3D Model. This can be seen in Process > Processing Options.... .

 

Indoor mapping - Spherical camera

The goal of this project is to generate the 3D model of a church taken by an NCTech iSTAR spherical camera. 
indoor_mapping_spherical.jpg
General project information
Project
Location "The Church of Santiago", located in Betanzos (A Coruña, Spain)
Average Ground Sampling Distance (GSD) Undefined
Area covered Undefined
Output coordinate system Arbitrary Coordinate System 
Image acquisition
UAV None
Image acquisition plan 2 walks in the church
Camera NCTech iSTAR
Images
Number of images 8
Image size 10000x5000
Image geolocation coordinate system Arbitrary Coordinate System
GCPs
Number of GCPs None
GCPs coordinate system None
Download project files

The dataset can be downloaded here.

The downloaded folder contains the following files and folders: 

  • images: RGB images in JPG format.
  • example_spherical.p4d: project file that can be opened in Pix4Dmapper.
Instructions
Process the dataset using the included .p4d project file

This section describes how to process the dataset in order to generate the 3D model of a building.

1. Open the project example_spherical.p4d by double clicking it. 
2. On the Menu bar, click View > Processing. The Processing bar opens at the bottom of the main window.

 
Note: As the goal of this project is to generate only the 3D model (no DSM or Orthomosaic), the template selected for processing is 3D Models. This can be seen in Process > Processing Options... .

 3. On the Processing bar, click Start to start the processing.

Process the dataset creating a new project

This section describes how to create and process a project in order to generate a 3D model of a building.

A) Create a new project:

1. Start Pix4Dmapper.
2. On the Menu bar, click Project > New Project....
3. The New Project wizard opens.
4. In Name: Type a name for the project. In this example, type example_spherical.
5. (optional) In Create In: click Browse..., and in the Select Project Location pop-up, navigate to select the folder where the project and results will be stored and click Select Folder.

 
Note: When the project is created, a folder named after the project name typed in the Name field will be created in the selected folder and will store all the results. The .p4d project file will also be stored in this folder.

6. (optional) Select the check box Use As Default Project Location to save all new projects in the selected folder.
7. In the section Project Type, keep selected the default option New Project.
8. Click Next.

The New Project wizard displays the Select Images window.

9. Click Add Directories... and select the images folder to add the images to the project.
10. Click Next.

The New Project wizard displays the Image Properties window. No image geolocation is detected.  The camera model is loaded from the camera model database (iSTAR_2.7_10000X5000(RGB)).

11.Click Next.

The New Project wizard displays the Select Output Coordinate System window. By default the last output coordinate system selected in the software is selected.

12. Select Arbitrary Coordinate System with Unit meters.
13. Click Next.

The New Project wizard displays the Processing Options Template window. 

 
Note: As the goal of this project is to generate only a 3D model (no DSM or orthomosaic), the template selected for processing is 3D Models.

14. Select the 3D Models template.
15. Click Finish to finish the wizard and create the project. The Processing bar opens at the bottom of the main window.

B) Process the project:

1. On the Processing bar, click Start to start the processing.

C) Improve the project:

To improve the results of the Densified Point Cloud and the 3D Textured mesh, the following Processing Options can be selected:

1. On the Menu bar click Process > Processing Options...
2. Select the processing step 1. Initial Processing.
3. Select the tab General.
4. In the section Keypoints Image Scale, select Custom and from the drop down list select 1 (Original Image size).

 
Note: This selection allows to extract the keypoints using the original image size. 

5. In the Processing Options window click 2. Point Cloud and Mesh.
6. Select the tab Point Cloud.
7. In the Point Cloud Densification section click the drop-down list Image scale and select 1 (Original Image size, Slow) and from the drop-down list Point Density select High (Slow).

 
Note: The original image size is used to compute additional 3D points. More points are computed especially in areas where features can be easily matched. By selecting High Point Density, a 3D point will be computed for every Image Scale pixel. For more information about the Processing Options: 202557799

8. Click OK.
9. On the Processing bar, click Start to start the processing.

 

Industrial building - Parrot Bebop 2

The goal of this project is to get a 3D model of industrial building. Images were acquired with Parrot Bebop 2 using Pix4Dcapture.
industrial_building_bebop2.png
General project information
Project
Location Nantes, France
Average Ground Sampling Distance (GSD) 9.25 cm / 3.64 in
Area covered 0.0113 km2 / 1.13 ha / 0.0043 sq. mi. / 2.79 acres
Output coordinate system WGS84 / UTM zone 30N
Vertical Coordinate System: MSL egm96
Image acquisition
UAV Parrot Bebop 2
Image acquisition software Pix4Dcapture
Image acquisition plan Grid Mission and Circular Mission
Camera Bebop 2 camera
Images
Number of images 138
Image size 4096x3320
Image geolocation coordinate system WGS84
Download project files

The dataset can be downloaded here and can be found processed on Pix4D Cloud here

The downloaded folder contains the following files and folders: 

  • imagesRGB images in JPG format.
  • example_bebop2_industrial_building.p4dproject file that can be opened in Pix4D Desktop.
Instructions
Process the dataset using the included .p4d project file

This section describes how to process the dataset in order to generate a 3D textured mesh of the building using Parrot Bebop 2.

1. Open the project example_bebop2_industrial_building.p4d.
2. On the Menu bar, click View > Processing. The Processing bar opens at the bottom of the main window.

 
Note: As the goal of this project is to generate the 3D textured mesh (no DSM and orthomosaic),  the template used for the processing has been set to 3D Models. This can be seen in Process > Processing Options...

3. On the Processing bar, click Start to start processing.

Process the dataset creating a new project

This section describes how to create and process a project in order to generate a 3D mesh of a house.

A) Create a new project:

1. Start Pix4D Desktop.
2. On the Menu bar, click Project > New Project....
3. The New Project wizard opens.
4. In Name: Type a name for the project. In this example type example_bebop2_industrial_building.
5. (optional) In Create In: Click Browse, and in the Select Project Location pop-up, navigate to select the folder where the project and results will be stored and click Select Folder.

 
Note: When the project is created, a folder with the same name as the project name typed in the Name field will be created in the selected folder and will store all the results. The .p4d project file will also be stored in this folder.

6. (optional) Select the check box Use As Default Project Location to save all new projects in the selected folder.
7. In the section Project Type, keep selected the default option New Project.
8. Click Next.

The New Project wizard displays the Select Images window.

9. Click Add Directories... and select the images folder to add the images to the project. The folder contains the images of the grid mission and circular flight. Click Choose.
10. Click Next.

The New Project wizard displays the Image Properties window. The image geolocation is automatically loaded from the image EXIF data and is given in WGS84 (latitude, longitude, altitude) coordinates with vertical coordinate system given by MSL = egm96. The camera model is loaded from the camera model database (Bebop2_1.8_4096x3320 (RGB)).

11. Click Next.

The New Project wizard displays the Select Output Coordinate System window. By default the last output coordinate system selected in the software is selected.

12. Select Known Coordinate System and Advanced Coordinate Options. Click From List... button, select World Geodetic System 1984 datum and  WGS 84 / UTM zone 30N coordinate system, click OK.
13. Under Vertical Coordinate System select MSL. Set the value to egm96.
14. Click Next.

The New Project wizard displays the Processing Options Template window.

15. Click 3D Models to select the template. Click Finish to finish the wizard. The Processing bar opens at the bottom of the main window.

B) Process the project:

16. On the Processing bar select 1. Initial Processing and deselect 2. Point Cloud and Mesh.
17. On the Processing bar, click Start to start processing.

 
Note: Pix4Dmapper automatically detects the sky in the images of Bebop2 and improves the Densified Point Cloud.
For more information about the Processing Options: 205327965

When Initial Processing finishes, the rayCloud opens.

18. Use the rayCloud to define a Processing Area to remove noisy points from the background and to keep only points of the building. For more information about how to draw a Processing Area with the rayCloud: 202560179.

 
Note: The Processing Area used:

industrial_building_bebop2_processing_area.png

19. Edit the Processing Area to focus on the area of interest. For more information about how to edit a Processing Area with the rayCloud: 202560599.

 
Note: In the above Processing Area, the Maximum and Minimum Altitude are set to 50.00 [m] and -10.00 [m] respectively.

20. On the Processing bar, deselect 1. Initial Processing, and select 2. Point Cloud and Mesh.
21. On the Processing bar, click Start to start processing.

 

Pix4Dag

Field RGB 

The goal of this project is to get an orthomosaic of a field using Sequoia.
sequoia_example_Rgb.png
General project information
Project
Location Switzerland
Average Ground Sampling Distance (GSD) 2.66 cm / 1.04 in
Area covered 0.184 km2 / 18.4179 ha / 0.0711 sq. mi. / 45.5351 acres
Output coordinate system WGS84 / UTM zone 32N
Vertical Coordinate System: MSL egm96
Image acquisition
UAV eBee (senseFly)
Image acquisition plan 1 flight, grid flight plan, 106 meters flight height
Camera Sequoia (RGB)
Images
Number of images 356
Image size 4608x3456
Image geolocation coordinate system WGS84
GCPs
Number of GCPs None
GCPs coordinate system None
Download project files*

The dataset can be downloaded here.

The downloaded folder contains the following files and folders: 

  • images: RGB images in JPG format.
  • rgb_dataset.p4d: project file that can be opened in Pix4Dmapper.

* This dataset is not authoritative. For questions regarding the latest camera software and tags, refer to the Parrot developer's forum or contact us.

Instructions
Process the dataset using the included .p4d project file

This section describes how to process the dataset in order to generate an orthomosaic.

A) Process the project:

1. Open the project rgb_dataset.p4d by double clicking on the file.
2. On the menu bar, click View > Processing. The Processing window opens at the bottom of the main window.

 
Note: As this project's goal is to generate an orthomosaic for an agricultural field, the Ag RGB template has been selected.

3. On the Processing window, click Start to start the processing.

 
Note: More information about how to process a project with Sequoia: 209362146
Process the dataset creating a new project

This section describes how to create and process a project in order to generate an orthomosaic for the whole project.

A) Create a new project:

1. Start Pix4Dmapper.
2. On the menu bar, click Project > New Project....
3. The New Project wizard opens.
4. In Name: Type a name for the project. In this example type rgb_dataset.
5. (Optional) In Create In: Click on Browse, and on the Select Project Location pop-up window, navigate to select the folder where the project and results will be stored and click Select Folder.

 
Note: When the project is created, a folder with the same name as the project name typed in the Name field will be created in the selected folder and will store all the results. The .p4d project file will also be stored in this folder.

6. (Optional) Activate the check box Use As Default Project Location to save all new projects in the selected folder.
7. In the section Project Type, keep selected the default option New Project.
8. Click Next.

The New Project wizard displays the Select Images window.

9. Click Add Directories... and select the images folder to add the images to the project.

10. Click Next.

The New Project wizard displays the Image Properties window. The image geolocation it is already set in the Image Properties window under section Image Coordinate System and does not need to be changed. The image geolocation is loadedThe camera model is loaded from the camera model database (Sequoia (RGB)).

11. Click Next.

The New Project wizard displays the Processing Options Template window.

 
Note: As this project's goal is to generate an orthomosaic for an agricultural field, the template to be selected is the Ag RGB template.

12. On the left of the window, select the Ag RGB template.
13. Click Next.

The New Project wizard displays the Select Output Coordinate System window.  By default the last output coordinate system selected in the software is selected.

14. Under Unit, select m.
15. Select Auto Detected.
16. Select Advanced Coordinate Options and under Vertical Coordinate System select MSL egm96.
17. Click Finish to finish the wizard and create the project. The Processing window opens at the bottom of the main window.

B) Process the project:

1. On the menu bar, click Process > Processing Options... to open the Processing Options window.
2. On the Processing window, click Start to start the processing.

Once processing is finished, the Orthomosaic can be visualized and modified in the Mosaic Editor.

 
Note: More information about how to process a project with Sequoia: 209362146

Field multispectral

The goal of this project is to get an NDVI index map of a field using the Sequoia camera that captures Green, Red, Red edge and NIR wavelengths.
sequoia_example_msp.jpg
General project information
Project
Location Switzerland
Average Ground Sampling Distance (GSD) 10.66 cm / 4.19 in
Area covered 0.2302 km2 / 23.0239 ha / 0.0889 sq. mi. / 59.9227 acres
Output coordinate system WGS84 / UTM zone 32N
Vertical Coordinate System: MSL egm96
Image acquisition
UAV eBee (senseFly)
Image acquisition plan 1 flight, grid flight plan, 106 meters flight height
Camera Sequoia (Green, Red, Red edge, NIR)
Images
Number of images 712
Image size 1280x960
Image geolocation coordinate system WGS84
GCPs
Number of GCPs None
GCPs coordinate system None
Download project files*

The dataset can be downloaded here and can be found processed on Pix4D Cloud here

The downloaded folder contains the following files and folders: 

  • images: Red, Green, Red edge and NIR images in TIFF format.
  • example_sequoia_msp.p4d: project file that can be opened in Pix4Dmapper.

* This dataset is not authoritative. For questions regarding the latest camera software and tags, refer to the Parrot developer's forum or contact us.

Instructions
Process the dataset using the included .p4d project file

This section describes how to process the dataset in order to generate an NDVI index map for some specific regions.

A) Process the project:

1. Open the project example_sequoia_msp.p4d by double clicking on the file.
2. On the menu bar, click View > Processing. The Processing window opens at the bottom of the main window.

 
Note: As this project's goal is to generate a NDVI Index Map, the Ag Multispectral template has been selected.

3. On the Processing window, click Start to start the processing.

 
Note: The Index Calculator can be used to generate indices for different regions of the project. More information can be found on our webinar and video about precision agriculture. 
More information about how to process a project with Sequoia: 209362146
Process the dataset creating a new project

This section describes how to create and process a project in order to generate a NDVI index map for the whole project.

A) Create a new project:

1. Start Pix4Dmapper.
2. On the menu bar, click Project > New Project....
3. The New Project wizard opens.
4. In Name: Type a name for the project. In this example type example_sequoia_msp.
5. (Optional) In Create In: Click on Browse, and on the Select Project Location pop-up window, navigate to select the folder where the project and results will be stored and click Select Folder.

 
Note: When the project is created, a folder with the same name as the project name typed in the Name field will be created in the selected folder and will store all the results. The .p4d project file will also be stored in this folder.

6. (Optional) Activate the check box Use As Default Project Location to save all new projects in the selected folder.
7. In the section Project Type, keep selected the default option New Project.
8. Click Next.

The New Project wizard displays the Select Images window.

9. Click Add Directories... and select the images folder to add the images to the project.

 
Note: The images of the Calibration Target must be selected for the Radiometric Calibration. In this particular project, Pix4Dmapper will automatically recognize the images of the Calibration target and will use them for the radiometric calibration. 

10. Click Next.

The New Project wizard displays the Image Properties window. The image geolocation it is already set in the Image Properties window under section Image Coordinate System and does not need to be changed. The image geolocation is loadedThe camera model is loaded from the camera model database (Sequoia (Red, Green, Red edge, NIR)).

11. Click Next.

The New Project wizard displays the Processing Options Template window.

 
Note: As this project's goal is to generate an NDVI Index Map, the template to be selected is the Ag Multispectral template.

12. On the left of the window, select the Ag Multispectral template.
13. Click Next.

The New Project wizard displays the Select Output Coordinate System window.  By default the last output coordinate system selected in the software is selected.

14. Under Unit, select m.
15. Select Auto Detected.
16. Select Advanced Coordinate Options and under Vertical Coordinate System select MSL egm96.
17. Click Finish to finish the wizard and create the project. The Processing window opens at the bottom of the main window.

B) Process the project:

1. On the menu bar, click Process > Processing Options... to open the Processing Options window.
2. On the Processing window, click Start to start the processing.

Once processing is finished, the NDVI Index Map can be visualized and exported in the Index Calculator.

 
Note: The Index Calculator can be used to generate indices for different regions of the project. More information about how to process a project with Sequoia: 209362146
Was this article helpful?
5 out of 6 found this helpful

Article feedback (for troubleshooting, post here)

0 comments

Please sign in to leave a comment.