エラー 0xc0000142 -PIX4Dmatic
この記事では、エラーコード 0xc0000142 の意味を解説し、その解決に向けた手順を順を追って説明します。以下の手順に従って、この問題を効果的にトラブルシューティングし、解決してください。
免責事項:この記事には 、追加情報への外部リンクが含まれています。これらのリンクは、あくまで利便性と参考情報として提供されているものであり、外部サイトのコンテンツや利用可能性については保証いたしません。
エラー
PIX4Dmatic起動中にエラー 0xc0000142 が表示され、ソフトウェアを使用できません。

原因
0xc0000142 は、Windows がアプリケーションを正しく起動できない場合に表示される一般的なエラーコードです。以下のいずれか、または複数の要因が原因である可能性があります:
-
ファイアウォールやウイルス対策ソフトによって、ソフトウェアがブロックされている可能性があります。ソフトウェアのアップデート後、ファイアウォールやウイルス対策ソフトが新しいバージョンを同じソフトウェアの一部として認識できず、接続がブロックされる場合があります。目次 」に記載されている例外設定を追加することをお勧めします:プロキシおよびファイアウォールの設定 -PIX4Dmatic
-
Pix4D で使用される 1 つ以上のシステム DLL ファイルが欠落しているか、破損しています
解決策
ヒント: 各解決策を試した後は 、Pix4D で問題が解消されたかどうかを必ず確認してください。
-
Pix4D (.exe)を「管理者として実行」するように設定します:
-
Pix4D (.exe)を右クリックし、「プロパティ」を選択します
-
「互換性」に移動する
-
「このプログラムを管理者として実行する」オプションにチェックを入れてください
-
「適用」をクリックしてウィンドウを閉じてください
-
-
PIX4Dmatic 完全に再インストールしてください:「を完全にアンインストールする方法」を参照し、権限を再度割り当ててください。
-
ファイアウォールおよび/またはウイルス対策ソフトに対し、Pix4D を実行する権限を付与してください(たとえば、ホワイトリストを更新するなど)。
-
お使いのコンピュータにCitrixとApp Protectionがインストールされている場合は、Pix4D に対してApp Protectionを無効にするか、App Protectionを無効にした状態でCitrixを再インストールしてみてください。
-
Windowsを最新の状態に保つ:
-
タスクバーのWindowsスタートボタンをクリックし、次のように入力します
更新 -
結果をクリックし、「 更新を確認」を選択してください
-
「更新を確認」ボタンを クリックしてください
-
更新プログラムがある場合は、ダウンロードしてインストールしてください
-
コンピュータを再起動してください。
-
-
GPUのドライバーが最新であることを確認してください。これは、AMDまたはNVIDIAのドライバー更新ツール(例:GeForce Experience)を使用して行うことができます。
-
チェックディスク(CHKDSK)ツールを実行します:
-
タスクバーのWindowsスタートボタンをクリックし、次のように入力します
ターミナル -
検索結果の「Terminal 」を右クリックし、「 」から 「管理者として実行」を選択します
-
ターミナルに以下を入力してください
chkdsk C: /f -
チェックのスケジュール設定を促された場合は、次のように入力してください
Yその後、コンピュータを再起動してください
-
-
DISM(Deployment Image Servicing and Management)ツールを実行する
-
タスクバーのWindowsスタートボタンをクリックし、次のように入力します
ターミナル -
検索結果の「Terminal 」を右クリックし、「 」から 「管理者として実行」を選択します
-
ターミナルに以下を入力してください
DISM.exe /Online /Cleanup-image /Restorehealth -
このツールに関する詳細はこちらをご覧ください
-
-
システム ファイル チェッカー (SFC) ツールを実行します:
-
タスクバーのWindowsスタートボタンをクリックし、次のように入力します
ターミナル -
検索結果の「Terminal 」を右クリックし、「 」から 「管理者として実行」を選択します
-
ターミナルに以下を入力してください
sfc /scannow -
このツールに関する詳細はこちらをご覧ください
-
-
互換性設定を変更する
-
Pix4D アイコンを右クリックし、「プロパティ」を選択します
-
「互換性」に移動する
-
「 このプログラムを互換モードで実行する 」をクリックし 、「 Windows 8」を選択してください
-
「適用」をクリックしてウィンドウを閉じてください
-
-
Windowsのレジストリの値を変更することで、一部のユーザーにおいてこの問題が解決されたとの報告があります。レジストリを変更する前に、バックアップを作成することをお勧めします
-
タスクバーのWindowsスタートボタンをクリックし、次のように入力します
regedit -
「 レジストリ エディタ」の結果をクリックしてください
-
以下のフォルダに移動してください:
HKEY_LOCAL_MACHINE→SOFTWARE→Microsoft→Windows NT→CurrentVersion→Windows -
「最終」をクリックすると
Windowsフォルダを開くと、右側にアイテムの一覧が表示されます -
をダブルクリックして
LoadAppInit_DLLsリストの中に -
この値を次のように変更してください
0「OK」をクリックします
-
-
サードパーティ製サービスなしでWindowsを起動する:
-
タスクバーにあるWindowsのスタートボタンをクリックしてください
-
種類
システム設定検索バーに入力し、検索結果をクリックしてください システム構成 -
「サービス」に移動する
-
「すべての Microsoft サービスを非表示にする」にチェックが入っていることを確認してください
-
「すべて無効にする」ボタンを押してください
-
コンピュータを再起動する
-
問題が解決したら、原因となっているサービスが見つかるまで、各サービスを順次有効にしてください
-
-
上記のいずれの方法でも問題が解決しない場合は、「Windows用デバッグツール」をインストールし、その結果をPix4D までお送りください:
-
Windows用のデバッグツールはこちらからダウンロードしてください
-
インストーラーを実行し、「Debugging Tools for Windows」にチェックが入っていることを確認してください。その他のオプションはすべてチェックを外しても構いません。
-
[ここに移動]
C:\Program Files (x86)\Windows Kits\10\Debuggers\x64 -
「Global Flags」の実行ファイル「gflags.exe」を開きます
-
[ここに移動] 画像ファイル そして入力してください
Pix4Dmatic.exeの横にあるテキストフィールドに 画像 -
Tabキーを押してすべてのオプションを有効にし、[ローダーのスナップを表示] にチェックを入れます
-
「適用」をクリックし、次に「OK」をクリックします
-
Windows デバッガー「windbg.exe」を開く
-
「ファイル 」をクリックし、 次に「実行ファイルを開く」をクリックします
-
Pix4D の場所まで移動し、「開く」をクリックします
- コンソールがログへの書き込みを中断した場合は、Pix4D が完全に起動するまで、F5キーを押して再開してください
-
-
-
出力ウィンドウのログをすべてテキストファイルにコピーし、サポートまでご連絡ください
-