This article explains the meaning of error 0xc0000142 and provides step-by-step solutions to help resolve it. Follow the guidance below to troubleshoot and address this issue effectively.
Disclaimer: This article includes external links to additional resources. These links are provided solely for convenience and reference, and the content or availability of external sites is not guaranteed.
Error
During the startup of PIX4Dmatic, the error 0xc0000142 appears and it is not possible to use the software.
Cause
0xc0000142 is a general error code for when Windows is unable to start an application correctly. One or more of the following may be the cause:
-
A firewall or an antivirus blocks the software. After a software update, the firewall or antivirus might not recognize the new version as part of the same software, so the connections are blocked. It is recommended to add the exceptions listed in this article as a first step: Proxy & Firewall configuration - PIX4Dmatic
-
One or more system dlls used by the Pix4D software are missing or corrupted
Solutions
Tip: After each possible solution be sure to check if the issue persists in the Pix4D software.
-
Set the Pix4D executable (.exe) to be run as administrator:
-
Right-mouse click on the Pix4D executable icon (.exe) and choose Properties
-
Navigate to Compatibility
-
Check the option Run this Program as Administrator
-
Click Apply and close the window
-
-
Completely reinstall PIX4Dmatic as described: How to completely uninstall and assign the permissions again.
-
Give the firewall and/or the antivirus permissions to run the Pix4D software (for example, by updating the whitelist).
-
If the computer has Citrix with App Protection installed, try disabling it for the Pix4D software or reinstalling Citrix with App Protection disabled.
-
Ensure Windows is up to date:
-
Click on the Windows start button in the Taskbar and type
update
-
Click on the result Check for updates
-
Click the Check for Updates button
-
If there are any updates, download and install them
-
Restart the computer.
-
-
Ensure that the GPU’s drivers are up to date. This can be done using the driver updating tool for AMD or NVIDIA (eg. GeForce Experience).
-
Install or repair Visual C++ Redistributables from the latest installer here.
-
Run the Check Disk (CHKDSK) tool:
-
Click on the Windows start button in the Taskbar and type
terminal
-
Right mouse click on the result Terminal and select Run as administrator
-
Type the following in the terminal
chkdsk C: /f
-
If prompted to schedule the check, type
Y
and then reset the computer
-
-
Run the Deployment Image Servicing and Management (DISM) tool
-
Click on the Windows start button in the Taskbar and type
terminal
-
Right mouse click on the result Terminal and select Run as administrator
-
Type the following in the terminal
DISM.exe /Online /Cleanup-image /Restorehealth
-
More information on this tool can be found here
-
-
Run the System File Checker (SFC) tool:
-
Click on the Windows start button in the Taskbar and type
terminal
-
Right mouse click on the result Terminal and select Run as administrator
-
Type the following in the terminal
sfc /scannow
-
More information on this tool can be found here
-
-
Modify Compatibility Settings
-
Right-mouse click on the Pix4D software icon and choose Properties
-
Navigate to Compatibility
-
Click on Run this program in compatibility mode for and choose Windows 8
-
Click Apply and close the window
-
-
It has been reported that modifying a value in the Windows registry has fixed this issue for certain users. Before modifying the registry it is recommended that a backup is performed
-
Click on the Windows start button in the Taskbar and type
regedit
-
Click on the result Registry Editor
-
Navigate the following folders:
HKEY_LOCAL_MACHINE
→SOFTWARE
→Microsoft
→Windows NT
→CurrentVersion
→Windows
-
Clicking on the final
Windows
folder will show a list of items on the right side -
Double-click on
LoadAppInit_DLLs
in the list -
Change this value to
0
and click Ok
-
-
Start Windows without third-party services:
-
Click on the Windows start button in the Taskbar
-
Type
system config
in the search bar and click on the result System Configuration -
Navigate to Services
-
Ensure Hide all Microsoft Services is checked
-
Press the Disable all button
-
Reset the computer
-
If the issue is fixed, enable again each service until the one causing the issue is found
-
-
If none of the above fixes the issue, install the Debugging tools for Windows and send the results to Pix4D Technical Support:
-
Download the Debugging tools for Windows here
-
Run the installer and make sure Debugging Tools for Windows is checked. All other options can be unchecked.
-
Navigate to
C:\Program Files (x86)\Windows Kits\10\Debuggers\x64
-
Open the Global Flags executable gflags.exe
-
Navigate to Image File and type
Pix4Dmatic.exe
in the text field next to Image -
Press Tab to enable all the options and then check Show loader snaps
-
Click Apply and then Okay
-
Open the Windows debugger windbg.exe
-
Click File and then Open Executable
-
Navigate to the Pix4D executable and click Open
- If the console stops writing to the log at any point, press F5 to continue, until the Pix4D application is fully open
-
-
-
Copy all logs from the output window into a text file and contact support
-