(Android and iOS) Which drones are supported by the app?

The status of Pix4Dcapture regarding the different drones, cameras, and controllers is described in the table below. When the app has not been tested, it means that the app could work but Pix4D makes no guarantee. Coming soon means the support is planned and should be available in maximum two months.

 
Information: Non-DJI camera mounted on DJI drones cannot fly with the app because the connection is broken between the camera and the drone. The best case would be that the drone follows the flight plan but the camera is not triggered and would require a time-lapse to activate the shutter. At the moment, it is not in the app development pipeline to test the possibility of flying with a non-DJI camera.

 

Manufacturer Drone / Camera / Controllers Android iOS
DJI drones Inspire 1 (with X3), called Inspire 1 V2.0 Compatible (2.0.6 and later) Compatible (1.0.0 and later)
Inspire 1 Pro (with X5) Compatible (2.1.1 and later) Compatible (1.2.0 and later)
Inspire 2 (with X4S) Compatible (3.8.1 and later) Compatible (1.7.1 and later)
Mavic Pro Compatible (3.5.0 and later) Compatible (1.6.0 and later)
Matrice 100 (with X3 or X5) Compatible (3.1.1 and later) Compatible (1.4.0 and later)
Matrice 600 Not tested Not tested
Phantom 1 Not compatible Not compatible
Phantom 2 Not compatible Not compatible
Phantom 2 Vision Compatible (2.0.6 and later) Compatible (0.4.0 and later)
Phantom 2 Vision+ Compatible (2.0.6 and later) Compatible (0.4.0 and later)
Phantom 3 Advanced Compatible (2.0.6 and later) Compatible (1.0.0 and later)
Phantom 3 Professional Compatible (2.0.6 and later) Compatible (1.0.0 and later)
Phantom 3 Standard Compatible (3.1.0 and later) Compatible (1.0.0 and later)
Phantom 3 4K Not tested Not tested
Phantom 4 Compatible (3.1.0 and later) Compatible (1.2.0 and later)
Phantom 4 Pro Compatible (3.6.0 and later) Compatible (1.6.1 and later)
Phantom 4 Pro+ Not compatible Not compatible
DJI cameras Zenmuse XT Not tested Not tested
Zenmuse X3 Compatible (2.0.6 and later) Compatible (1.0.0 and later)
Zenmuse X4S Compatible (3.8.1 and later) Compatible (1.7.1 and later)
Zenmuse X5 Compatible (2.1.1 and later) Compatible (1.2.0 and later)
Zenmuse X5R Not tested Not tested
Zenmuse X5S Not tested, compatible (3.8.1 and later) Not tested, compatible (1.7.1 and later)
Zenmuse Z3 Not tested Not compatible
Zenmuse Z30 Not tested Not compatible
Parrot drones Bebop 1 Not compatible Not compatible
Bebop 2 Compatible (2.1.1 and later) Compatible (1.1.0 and later)
Parrot controllers Skycontroller Compatible (2.1.1 and later) Compatible (1.1.0 and later)
Skycontroller 2 Coming soon Compatible (1.6.0)
3DR Solo (with GoPro Hero 4 Black or Silver) Compatible (3.0.1 and later), beta Not compatible

 

Recommendations to fly a drone that was not tested

The drone to be selected before starting a mission should be one of those having the same connection mode (Wi-Fi or USB cable).

 
Tip: The following drone are recommended:
  • DJI Matrice 600: Select Matrice 100 or Inspire 1.
  • DJI Phantom 3 4K: Select Phantom 3 Advanced or Professional.

 


Powered by Zendesk