アウトプットが表示されない/ Pix4Dcloudで機能がない

Pix4Dcloudでプロジェクトを作成した後で、次の問題が発生する場合があります。

  • 2Dビュー:オルソモザイク/DSM/指数マップが表示されない。
  • 3Dビュー:点群/3Dテクスチャメッシュが表示されない。
  • 標高プロファイルがロードされない。
  • 体積を計算できない。

Pix4Dmapperからアップロードされたプロジェクトの場合

以下の一覧に示す問題が発生する可能性があります。

 
注:アウトプットが得られない問題の原因が、アップロード前にPix4Dmapperで選択された処理オプションにあることがよくあります。処理オプションは.p4dファイルに保存されています。Pix4Dcloudサーバーは、アップロードされたプロジェクトファイル(.p4d)に基づいて画像を処理するため、目的のアウトプットがエクスポート対象として選択されていなかったり、目的のアウトプットを生成する処理ステップが実行対象に指定されていなかったりすると、この問題が発生します。
エラーの説明
原因/解決方法
「DSM」または「オルソモザイク」、あるいはその両方が2Dビューに表示されません。「ファイル」>「結果」セクションの「DSM」または「オルソモザイク」には「EMPTY」ステータスが表示されます。

アップロードの前に、適切なアウトプット形式が選択されませんでした。

1. Pix4Dmapperで、プロジェクトを再度開きます。メニューバーの「処理」>「処理オプション」をクリックします。
2. 処理ステップ「3. DSM、オルソモザイク及び指数」を選択します。
3. ステップ「3. DSM、オルソモザイク及び指数」に対応するチェックボックスをオンにします。
4. 「DSMとオルソモザイク」タブを選択します。
5. 目的のアウトプットに対応する「GeoTIFF」ボックスをオンにします。「タイルをマージする」ボックスは無視してください。
詳細については、「Menu Process > Processing Options... > 3. DSM, Orthomosaic and Index > DSM and Orthomosaic」を参照してください。
6. プロジェクトをPix4Dcloudに再アップロードします。

「DSM」または「オルソモザイク」、あるいはその両方が「2Dビュー」に表示されません。「オルソモザイク」レイヤーには、「このレイヤーを表示できません」という警告メッセージが表示されます。「ファイル」>「結果」セクションの「DSM」または「オルソモザイク」には「PROCESSED」ステータスが表示されます。そのDSMまたはオルソモザイクのサイズが大きすぎるか、形状が複雑であると考えられます。

このエラーは、アウトプットのサイズが大きすぎるか、形状が複雑であることが原因で発生していると考えられます。その場合、タイル処理が失敗し、生成された2Dアウトプットを一部のズームレベル用に小さなウェブマップ(タイル)に分割できなくなります。それが原因で、アウトプットを表示できなくなっています。アウトプットは生成されており、実際に「結果」ページでダウンロードできますが、ファイルが大きすぎるためPix4Dcloudの2Dビューでは表示できません。

現時点では、以下の要因がタイルの生成速度に影響を与えていると考えられています。

  • ファイルのサイズが非常に大きい(大きな面が存在する、解像度が高い、膨大な数のポイントがある)。
  • プロジェクトの座標系を、ウェブマップで使用されるWGS84に変換するために、複雑な地理的変換が行われる。
  • コリドープロジェクト。
  • 一様なタイルが使用されない、複数ブロックのプロジェクト。

次の解決策をお勧めします。

  • サードパーティ製のソフトウェアを使用してファイルを複数の部分に分割し、各部分をPix4Dcloudの別々のプロジェクトに再アップロードする。
  • 小さなファイルに置き換える。
  • Pix4Dmapperで処理範囲を定義してから、プロジェクトをPix4Dcloudにアップロードして処理する。
  • タイル処理には、画像の数、画像の内容とテクスチャ、モデル形状の複雑さ、地理的変換など、さまざまな要因が影響を及ぼします。そのため、ファイルサイズがどの程度であればタイル処理のエラーが発生しないのか、正確なサイズを特定することはできません。
2Dビューに「NDVI」が表示されません。「ファイル」>「結果」セクションでは、NDVIのステータスが「EMPTY」になります。

アップロードの前に、適切なアウトプット形式が選択されませんでした。

1. Pix4Dmapperで、プロジェクトを再度開きます。メニューバーの「処理」>「処理オプション」をクリックします。
2. 処理ステップ「3. DSM、オルソモザイク及び指数」を選択します。
3. ステップ「3. DSM、オルソモザイク及び指数」に対応するチェックボックスをオンにします。
4. 「指数計算機」タブを選択します。
5. 「反射率マップ」の下にある「GeoTIFF」ボックスをオンにして、「反射率マップ」が生成されるようにします。「タイルをマージする」ボックスは無視してください。
6. NDVI式のボックスをオンにして、「NDVI指数マップ」が生成されるようにします。
詳細については、「Menu Process > Processing Options... > 3. DSM, Orthomosaic and Index > Index Calculator」を参照してください。
7. プロジェクトをPix4Dcloudに再アップロードします。

「3Dビュー」「点群」が表示されません。「ファイル」>「結果」セクションでは、「点群」「EMPTY」ステータスが表示されます。

アップロードの前に、適切なアウトプット形式が選択されませんでした。

1. Pix4Dmapperで、プロジェクトを再度開きます。メニューバーの「処理」>「処理オプション」をクリックします。
2. 処理ステップ「2. 点群とメッシュ」を選択します。
3. ステップ「2. 点群とメッシュ」に対応するチェックボックスをオンにします。
4. 「点群」タブを選択します。
5. 「LAS」ボックスをオンにします。
詳細については、「Menu Process > Processing Options... > 2. Point Cloud and Mesh > Point Cloud」を参照してください。
6. プロジェクトをPix4Dcloudに再アップロードします。

「3Dビュー」「3Dテクスチャメッシュ」が表示されません。「ファイル」>「結果」セクションでは、「メッシュOBJ」「EMPTY」ステータスが表示されます。

アップロードの前に、適切なアウトプット形式が選択されませんでした。

1. Pix4Dmapperで、プロジェクトを再度開きます。メニューバーの「処理」>「処理オプション」をクリックします。
2. 処理ステップ「2. 点群とメッシュ」を選択します。
3. ステップ「2. 点群とメッシュ」に対応するチェックボックスをオンにします。
4. 「3Dテクスチャメッシュ」タブを選択します。
5. 「3Dテクスチャメッシュを生成する」ボックスをオンにします。
6. 「OBJ」ボックスをオンにします。
詳細については、「Menu Process > Processing Options... > 2. Point Cloud and Mesh > 3D Textured Mesh」を参照してください。
6. プロジェクトをPix4Dcloudに再アップロードします。

Pix4Dcloudで作成され処理されたプロジェクトの場合

一般的なエラーをいくつか以下に示します。

エラーの説明
原因/解決方法

「DSM」または「オルソモザイク」、あるいはその両方が2Dビューに表示されません。「オルソモザイク」レイヤーには、「このレイヤーを表示できません」という警告メッセージが表示されます。「ファイル」>「結果」セクションの「DSM」または「オルソモザイク」には「PROCESSED」ステータスが表示されます。そのDSMまたはオルソモザイクのサイズが大きすぎるか、形状が複雑であると考えられます。

このエラーは、アウトプットのサイズが大きすぎるか、形状が複雑であることが原因で発生していると考えられます。その場合、タイル処理が失敗します。つまり、生成された2Dアウトプットを一部のズームレベル用に小さなウェブマップ(タイル)に分割でません。それが原因で、アウトプットを表示できなくなっています。アウトプットは生成されており、実際に「結果」ページでダウンロードできますが、ファイルが大きすぎるためPix4Dcloudの2Dビューでは表示できません。

現時点では、以下の要因がタイルの生成速度に影響を与えていると考えられています。

  • ファイルのサイズが非常に大きい(大きな面が存在する、解像度が高い、またはポイント数が多い)。
  • プロジェクトの座標系を、ウェブマップで使用されるWGS84に変換するために、複雑な地理的変換が行われる。
  • コリドープロジェクト。
  • 一様なタイルが使用されない、複数ブロックのプロジェクト。

次の解決策をお勧めします。

  • サードパーティ製のソフトウェアを使用してファイルを複数に分割し、それをPix4Dcloudの別々のプロジェクトに再アップロードする。
  • 小さなファイルに置き換える。
  • Pix4Dmapperで処理範囲を定義してから、プロジェクトをPix4Dcloudにアップロードして処理する。
  • タイル処理には、画像の数、画像の内容とテクスチャ、モデル形状の複雑さ、地理的変換など、さまざまな要因が影響を及ぼします。そのため、ファイルサイズがどの程度であればタイル処理のエラーが発生しないのか、正確なサイズを特定することはできません。

Pix4Dcloudで一部の結果がアップロードまたは置き換えられた場合

エラーの説明
原因/解決方法
「点群」および「3Dテクスチャメッシュ」結果としてアップロードされ、「3Dビュー」に表示の問題が発生します。

この問題は、マージされたビューア/エディタで、ジオリファレンス処理されていない3Dメッシュとジオリファレンス処理された点群が同時に表示されることが原因で発生します。クラウドに結果としてアップロードされたメッシュ(.obj、.jpg、.mtl)が、実際にはジオリファレンス処理されていません。ただし、アップロードされたメッシュをジオリファレンス処理することもできます。

1. プロジェクトを開き、「ファイル」>「結果」に移動します。
2. 「メッシュOBJ」セクションの「ファイルを置き換える」をクリックします。
3. 「..\1_initial\params」フォルダにある「project_name_offset.xyz」ファイルを選択して、「開く」をクリックします。
4. メッシュファイル(.obj、.jpg、.mtl)をアップローダーにドラッグアンドドロップします。

または、「project_name_offset.xyz」ファイルを「..\2_densification\3d_mesh」フォルダにコピーした後で、.obj、.jpg、.mtl、.xyzの4個のファイルを「メッシュOBJ」セクションにドラッグアンドドロップします。

「点群」が部分的に表示されません。複数のLASタイルファイルがローカルで生成され、アップロードされました。

結果としてPix4DcloudにアップロードできるLASファイルは、1個のみです。

このケースでは、Pix4Dcloudが一度に1個のファイルしかロードできないため、1個のタイルのみが表示される状態になっています。

「点群のタイルをマージする方法」を参照して、Pix4Dmapperで作成されたタイルをマージし、マージ後のLASファイルをアップロードするか、サードパーティ製ソフトウェアを使用してタイルをマージしてください。

3Dビューでメッシュファイルがレンダリングされません。OBJ 3Dテクスチャメッシュの大きさが1 GBを超えています。

Pix4Dcloudでは、大きさが1 GB未満のOBJメッシュファイルのレンダリングがサポートされています。OBJ 3Dテクスチャメッシュが1 GB未満であることを確認してから、Pix4Dcloudにアップロードしてください。

3Dビューでメッシュファイルがレンダリングされません。JPGテクスチャファイルの大きさが16384 x 16384を超えています。

Pix4Dcloudでは、大きさが16384 x 16384以下のJPGテクスチャ画像を含む3Dテクスチャメッシュファイルがサポートされます。JPGテクスチャファイルの大きさがこれ以下であることを確認してから、Pix4Dcloudにアップロードしてください。

その他の一般的なエラー

エラーの説明
原因/解決方法

プロジェクトのステータスが「UPLOADED」ですが、UIにレイヤーが含まれていません。

プロジェクトファイルをPix4Dmapperからアップロードする際に、 「処理の開始」が選択されていませんでした。その後、「ファイル」>「結果」セクションから結果がアップロードされました。

そのためPix4Dcloudには、(フォトグラメトリー関連の)処理のための画像とp4dファイルに加えて、結果が送られますが、この結果はWeb表示用に最適化する必要があります。このワークフローの結果、Pix4Dcloudでは画像と結果のどちらの処理を開始するべきなのか判断できなくなり、プロジェクトのステータスがスタック状態となります。

結果に処理を加えずにアップロードしたいのであれば、p4dファイルと画像は不要なため、Pix4Dcloudにアップロードしないでください。

こちらの説明に従って、新しいデータセットを作成してから結果をアップロードしてください。

3Dビューがレンダリングされません。

Webブラウザーが、3Dグラフィックスのレンダリングに最適化されたWebGLをサポートしていることが必要です。これは、一部のiOSデバイスにおける既知の問題です。詳細については、ArcGISのヘルプと、Sketchfabのヘルプを参照してください。

Pix4Dcloudにアクセスできません。または、Pix4Dcloudプロジェクトで一部のツールを使用できません。

最初に、使用しているブラウザーが最新バージョンであるかどうか確認します。Pix4Dcloudでサポートされるインターネットブラウザーとオペレーティングシステムについては、Pix4Dcloud - FAQを参照してください。

インターネットブラウザーとオペレーティングシステムの組み合わせによっては、Pix4Dcloudの一部の機能、またはすべての機能がサポートされない場合があります。

  • Internet Explorer 11とWindows 10の組み合わせでは、Pix4Dcloudで使用できる機能が制限されます。標高プロファイルの生成など、一部のツールが使用できなくなります。
  • Internet Explorer 11とWindows 7の組み合わせは、正式にサポート対象外となっています。

標高プロファイルが見つかりません。

次のいずれかの原因が考えられます。

  • 右上にある「共有」ボタンをクリックすることで、プロジェクトの結果を共有することができます。2Dビューまたは3Dビューのコンテンツはアノテーションを含めてすべて共有されますが、標高プロファイルは共有されず、毎回再トリガーする必要があります。
  • 3Dメッシュがオフセットファイルなしで結果としてアップロードされた場合、ジオリファレンス処理されません。このアウトプットに対して生成された標高プロファイルは取得できなくなります。
  • プロジェクトが処理用にアップロードされるか、結果がPix4Dcloudにアップロードされた後で、アウトプットの1つがプロジェクトと座標系が異なる新しいアウトプットに置き換えられた場合、置き換えられたアウトプットで生成されていた標高プロファイルは取得できなくなります。

体積を計算する際にエラーが発生します。

以下のいずれかの状況が発生すると、体積が計算されなくなります。

  • 使用できるDSMがない
  • 3DメッシュがPix4Dcloudインターフェースからアップロードされており、その3Dメッシュに基づいて体積が計算されている(メッシュ上に描画されているベース面がDSMの有効な領域と交差していない)
  • 使用されている座標系が有効なものとして認識されていない
  • 座標系が任意座標系である

画像がマルチスペクトルカメラで撮影されています。

フルカラーのオルソモザイクが1つ生成されるのではなく、帯域ごとに1つずつGeoTIFFファイルが生成されます。Pix4Dcloudプラットフォームでは、DSMアウトプットおよびNDVIアウトプットのみが表示されます。ただし、GeoTIFFファイルはすべてダウンロード可能です。詳細については、Pix4Dcloudから結果をダウンロードする方法を参照してください。

プロジェクトが「エラー」ステータスです。

サーバーでプロジェクトが処理されませんでした。この問題のトラブルシューティングを行うには、さまざまなリードを調査することをお勧めします。詳細については、Pix4Dcloudでプロジェクトを処理中にエラーが発生を参照してください。

この記事は役に立ちましたか?
6人中0人がこの記事が役に立ったと言っています

Article feedback (for troubleshooting, post here)

0件のコメント

サインインしてコメントを残してください。