Weird Navigation Problem - laptop screen vs. external monitor

I'm doing some demo/trials with a new employer, hopefully to ultimately prove the worth of implementing a drone/photogrammetry program.   So for now I'm stuck with some fairly basic hardware....though it seems reasonably powerful enough to accomplish my current goal.  

The laptop is a ThinkPad P52s - i7-8550U @ 80GHz, 32GB RAM, Intel HD graphics 620 and NVIDIA Quadro P500.  I have an external monitor connected though a ThinkPad USB-C dock.

The problem I'm running in to is when I have a project open, everything seems to work and navigation in "standard" mode is as expected ONLY when I'm using the laptop's monitor.   If I flip Pix4D over to my external monitor without changing anything else, it becomes impossible to navigate.  None of the controls react the way you'd expect.   It's almost like a mix of trackball & first person modes.  I've tried closing the latop's "lid" and using only the external monitor.  I've also tried bypassing the dock and connecting the monitor straight to the HDMI output on the laptop.  Nothing so far has had an effect on the issue.  

 

I'm convinced it's a graphics issue, but I'm stumped on where to go.  I've tweaked some of the settings in the NVIDIA panel, but haven't seen any change and I really don't see anything that would cause this problem.

 

Any tips on where I can start?

3 comments

Please sign in to leave a comment.