How to use the Region of Interest in PIX4Dmatic

Follow

A Region of interest is a delimiting area to reduce the extent of outputs generated for a project, speed up the processing, or even create sharper outputs.

 
Important:
  • Only one Region of interest per project can be drawn.
  • It is recommended to exclude areas of low overlap that could affect the results.

Effects of a Region of Interest

 The Region of interest can be used to restrain the processing and can be valuable for different key aspects such as:

  • Optimizing the required storage of a project.
  • Increase the processing speed of a project.
  • Reducing the required hardware needed for processing a project.
  • Creating better outputs with sharper edges.
  • Generate results for a restricted area of the project by excluding the surroundings of the area of interest, i.e. due to oblique imagery.
Tip: If you want to include the whole project extent to generate results, consider drawing a region that is larger than the project area.

How to draw a Region of interest in the 2D view

 
Access: To access the Region of interest:
  • On the menu bar, click View > Switch to 2D, or click the 2D button on the screen, or use shortcut 2 to access the 2D view.
  • On the menu bar, click View > Region of interest, or on the Tools bar, select the Region of interest tool by clicking processing_area.jpg, or use shortcut O to access the Region of interest.

PIX4Dmatic_region_of_interest.png

Region of interest selection.

To draw a Region of interest in the 2D view:

  1. After selecting the Region of interest left-click to place the first vertex and then release the mouse button.
  2. To place the following vertices move the mouse to the desired location and left-click, then release the mouse button.
  3. (Optional) Click Esc to cancel the creation of the area.
  4. Right-click for the last vertex to close the polygon.
  5. Click File > Save to save the Region of interest in the project.
Note: It is possible to draw a Region of interest at any stage of the processing. It is recommended to add it before the Calibrate or the Densify step in order to have an immediate effect. Adding a Region of interest after the Densify step requires reprocessing to have an impact on the results.

How to edit a Region of interest in the 2D view

To edit the Region of interest or correct the position of each vertex:

  1. Access the 2D view from the menu bar, the toolbar, or the keyboard shortcut.
  2. Select the Region of interest by clicking anywhere inside its area, so that the vertices become visible.
  3. Click on a vertex to select it.
  4. Drag the vertex to move it to the correct position.
  5. (Optional) Click Esc to exit the Region of interest mode.
  6. (Optional) To remove an individual vertex, left-click on the specific vertex to select it and press the Delete button on the keyboard.
  7. (Optional) To add a new vertex, right-click on the position of the drawn polygon where the vertex needs to be added.
  8. Click outside the Region of interest to accept the modifications.
Note: The Region of interest cannot be drawn or edited in the 3D view. It can only be drawn or edited in the 2D view.
Note: When there are less than or equal to 3 vertices in the Region of interest, the deletion of a vertex is not possible.

How to delete a Region of interest

To remove the Region of interest:

  1. Access the 2D View from the menu bar, the toolbar, or the keyboard shortcut. Select the Region of interest by clicking anywhere inside its area, so that the vertices become visible.
  2. To remove the Region of interest, press Delete.
  3. (Optional) Draw it again from scratch if needed.
Note: It is possible to remove or delete a Region of interest only if it has already been drawn.
Was this article helpful?
0 out of 0 found this helpful

Article feedback (for troubleshooting, post here)

0 comments

Article is closed for comments.