Troubleshooting

"Failed to authenticate. Could not authenticate. There was a network issue." - PIX4Dfields

 
Error

"Failed to authenticate. Could not authenticate. There was a network issue."

failed_to_authenticate_round.jpg

Description
  • Error when logging in PIX4Dfields Desktop or ParrotFields.
  • Error when starting a trial period.
  • Error when trying to download satellite images.
Cause

There is a proxy/antivirus/firewall on the PC that does not allow the application to validate the HTTPS certificate chain. As a result, communication with the PIX4D server is impossible.

Solution

To solve the problem, the user (or system admin) needs to add an exception to the proxy/antivirus/firewall for one of the following options:

  • PIX4Dfields (Windows or macOS)
  • Domains:
    • *.pix4d.com
    • *.*.pix4d.com
    • *.*.*.pix4d.com
    • services.sentinel-hub.com
    • *.deere.com
Information: The exception should be either for all ports OR port 443 (HTTPS).
Examples of firewall configurations