CUDA not detected

Error

No NVIDIA CUDA capable devices found. Ensure that you use a CUDA compatible device with the latest drivers.

Description

Pix4Dmapper is compatible with any GPU that is compatible with OpenGL 3.2 or above. That means that Pix4Dmapper should work with low performances Intel integrated graphics card HD 4000 and above. However, for faster processing, Pix4Dmapper also uses the processing power of GPUs that are compatible with Nvidia CUDA 9.1 and above (with the latest drivers installed). That allows increasing the performance in Pix4Dmapper, especially during Step 1 and with large projects.

Cause

  • The GPU is not compatible with Nvidia CUDA 9.1 and above.
  • The latest drivers are not installed.

Solution

You can download the latest drivers for your graphics card from NVIDIA website here.

 
Important: In the case of two GPUs; it is not possible to install two different drivers sets. Therefore, you should install one that supports both cards. It always has to be the latest driver. However, between two to choose, it is essential to choose older to manage both cards.

 

Was this article helpful?
0 out of 1 found this helpful

Article feedback (for troubleshooting, post here)

0 comments

Please sign in to leave a comment.