"This app has been blocked for your protection" warning when installing Pix4D desktop applications on Windows 10

Error

"This app has been blocked for your protection". 

Windows_warning.jpg

Description

The company that issued the certificate used for signing the MSI installation files of Pix4D desktop applications declared bankruptcy a few days ago.
This means that if your version of Windows is up to date, Microsoft puts this certificate issuer on a blacklist and therefore the signed software could not be installed or uninstalled.

 
Information: This is only a warning and does not present an actual threat when using the software. Keep in mind that we recommend using the official installation files downloaded from the Pix4D download page.

Solutions

 
Important: The proposed solutions might not work if a Pix4D desktop application with the expired certificate is already installed. In this case, we recommend first uninstalling the software using administrator rights as described in 3. Uninstalling a Pix4D desktop application with the old certificate before installing other versions.

1. (Recommended) Download and install a Pix4D desktop application with the new certificate 

The following versions have the new certificate and are not blocked by Windows 10:

2. Installing a Pix4D desktop application with the old certificate

This workflow applies for all versions besides Pix4Dmapper versions 4.2.27, 4.3.24, 4.3.33, 4.4.10 and newer and Pix4Dfields versions 1.3.0 and newer.

 

Instead of directly opening the .msi, install the software using administrator rights:

  • Locate the .msi file.
  • Copy the full path of the .msi file. To copy the full path, hold shift while right-clicking on the file and select Copy as path.
  • Open the Start Menu on Windows.
  • Search for Command Prompt.
  • Right click on the Command Prompt icon in the Start Menu.
  • Select Run as administrator.
    Command_promp.jpg
  • Copy the full path of the .msi file into the Command Prompt.
    Command_prompt.jpg
  • Press Enter to install the software.

3. Uninstalling a Pix4D desktop application with the old certificate

(Recommended) Download and install a Pix4D desktop application with the new certificate (4.3.33 or 4.4.10 and newer). This way the version with the old certificate will be automatically removed.

 

(Optional) It is possible to uninstall the software using administrator rights:

  • Open the Start Menu on Windows.
  • Search for Command Prompt.
  • Right click on the Command Prompt icon in the Start Menu.
  • Select Run as administrator.
    Command_promp.jpg
  • Type wmic and press Enter.
  • (Pix4Dmapper) Type product where name="Pix4Dmapper" call uninstall and press Enter.
  • (Pix4Dfields) Type product where name="Pix4Dfields" call uninstall and press Enter.
  • If prompted, type Y to confirm uninstalling the program, and press Enter.
    Command_prompt_uninstal_1l.jpg
Was this article helpful?
4 out of 5 found this helpful

Article feedback (for troubleshooting, post here)

8 comments

  • Jim Bui

    I'm a first time demo user, and this error really didn't help getting started.  Had a hard time finding this post without additional keywords such as UAC or User Account Control.  Once I found this post, I got Pix4D Mapper desktop to install.  Consider adding a date somewhere in the article so users know if this is a recent bug or when it's fixed?

  • Blaž (Pix4D)

    Hi Jim, 

    Thank you for the comment.

    We just released a new version of the software that contains the new certificate.

    I recommend downloading and installing one of the latest versions of the software (4.2.27, 4.3.33 or 4.4.10) where the issue is solved.

    Best,

  • Leonardo Corral

    I have a question, we paid for a perpetual license and it shows the following: Support & Upgrade expired.

     

    can you please explain to us why is it requesting for a paid upgrade? 

     

    We are having issues to install the 4.3.31 version wich is the one we have access to download and use. 

     

    Thank you

  • Momtanu (Pix4D)

    Hi Leo,

    Support and updates are only required to update the software to the current version and to get support from our technical support engineers. I checked our system and the last version you have access to is 4.3.31 as you said and you should be able to use that. Are you getting the same error as here?

  • Johansen Pena

    That makes no sense. I bought a FULL license and it says that I can only install up to version 4.2.26. It does not let me install in WINDOWS 10 ...

    I pay so much money for that? I do not understand.

  • Momtanu (Pix4D)

    Hi Johansen,

    You can upgrade up to the version which was released before your S&U expired. Can you give me your email ID to check in our system? 

    What error are you getting when you install? If you get the error above, you will have to follow the instructions discussed above.

  • michael bolduc

    Same issue here, my last version is 4.3.31 and when I download it, I have this message. I can download 4.3.33 but I can run it only in discovery mode.

    I test 4.4.12 on trial, the trial expired yesturday, I make my windows 10 update yesturday night and this morning I can't install my old version, that's great.

    I follow all the instructions above, but 4.3.24 and 4.2.27 are not in my list of choice

    I can not process my ebee flight with Pix4D

     

Please sign in to leave a comment.