How to share KML files

Follow

To share the KML file, it is needed to share both the KML file and the tiles of the different zoom levels stored in folders. If only the KML file is shared, Google Earth will focus on the area, but the tiles will not be loaded. In order to share KML file and all zoom levels, it is convenient to create a KMZ file: a compressed version of the KML file. The KMZ file contains all the tiles and coordinate information needed to load the file.  

There are several ways to generate KMZ file:

A. Using File Explorer:

1. Select the google_tiles folder in project_name\3_dsm_ortho\2_mosaic.
2. Right-click on the folder and click Send to > Compressed (zipped) folder.
3. Share the compressed folder google_tiles.zip

 
Note: The recipient has to uncompress the folder on his computer. The file can then be opened by double-clicking the kml file or by dragging and dropping it into Google Earth.

B. Using external GIS software like Global Mapper:

1. Import orthomosaic in Global Mapper.
2. Click File > Export > Export Web Format > KML/KMZ (Any Data as Images). A kml file will be generated that does not require any sub-folder. 

 

 

Was this article helpful?
5 out of 13 found this helpful

Article feedback (for troubleshooting, post here)

9 comments

  • saurabh gala

    Hi My Name is Saurabh Gala from India
    I want help regarding land maping plz help me.
    I have one project of land maping but i want export fill of map in kml former.
    So i want to know if your software dosed that so i can buy it.

  • Avatar
    Beata (Pix4D)

    Hi Saurabh,

    Yes, you can generate a map (orthomosaic) in the KML format with Pix4Dmapper by following the instructions in the article How to generate the Google Maps Tiles and KML. When you will want to share the KML file with others, follow the instructions from the article above.

    Cheers!

  • Francisco Baptista de Gouveia

    Hello PIX4D TEAM, how are you guys?
    We are having here some issue that we don't have figured yet what are we doing wrong with it...
    Loading some KML or KMZ GOOGLE EARTH files, the PIX4D APP in ANDROID 6 says the files "don't have data that can BE uses by PIX4D", can you tell how we can get trought this ISSUE that is keeping US from using that files and that PRECIOUS information? URGENT PLEASE, THANK YOU SO MUCH...

    Edited by Francisco Baptista de Gouveia
  • Avatar
    Gaël (Pix4D)

    Hello Francisco,

    If my understanding is correct, you try to upload a .kml/.kmz file using Pix4Dcapture, am I right?
    In this case, you can follow this procedure
    I would maybe suggest you double check the file you try to import and maybe regenerating a new one if possible.

    Best,

  • Fernando Delgado

    Hola

    mi nombre es Fernando, me gustaría saber si puedo generar un archivo kml y copiarlo a mi aplicación del DJI agras MP1 ( en el control del drone) y de esa manera volar sobre la rejilla que se generó, pueden ser lineas de 1 o mas kilometros separadas por 50 metros.

    Saludos

  • Avatar
    Marco (Pix4D)

    Hola Fernando García,

    Primero, escribió en el artículo del producto equivocado.
    Aquí está dedicado a Pix4Dmapper.
    Entonces sólo se puede importar archivos kml en la versión Android de Pix4Dcapture, pero no se puede usar para definir el vuelo.
    https://support.pix4d.com/hc/en-us/articles/218051003-Android-Import-kml-kmz-file
    Si está usando una aplicación DJI, le sugiero que se ponga en contacto con ellos.

    Saludos

  • douglas staniszewski

    Per instructions:

    There are several ways to generate KMZ file:

    A. Using File Explorer:

    1. Select the google_tiles folder in project_name\3_dsm_ortho\2_mosaic.
    2. Right-click on the folder and click Send to > Compressed (zipped) folder.
    3. Share the compressed folder google_tiles.zip

    my folder is named tiles, not google_tiles......?????is this correct??

     

     

     

     

  • douglas staniszewski

    Does step 2 below take place in the external software?

    Step one says to import, step 2 says export???

    B. Using external GIS software like Global Mapper:

    1. Import orthomosaic in Global Mapper.
    2. Click File > Export > Export Web Format > KML/KMZ (Any Data as Images). A kml file will be generated that does not require any sub-folder. 

  • Marco Paccagnella

    Hi Douglas,

    The folder that contains the KML files is named google_tiles, not tiles

    The folder tiles contains the .tiff tiles of the orthomosaic, not the KML tiles.

    To generate the KML: How to generate the Google Maps Tiles and KML

    Yes, the method B mentioned above B. Using external GIS software like Global Mapper takes place in Global Mapper that is an external software

     

     

    Edited by Marco Paccagnella
Article is closed for comments.