3D Modeling with Parrot Bebop 2 - FAQ

 
Video: Watch the instructional video about Pix4Dmodelhere.

This article aims at detailing the workflow and best practices to use Pix4D products for real estate purposes with a Parrot Bebop 2 to capture images.

 

How can I get access to Pix4D products?

For real estate applications with a Bebop 2, Pix4Dmodel is a hybrid solution that gives unlimited access to Pix4D desktop, cloud and app. Additional information about Real Estate and Pix4Dmodel can be found on Pix4D website.

What does the Pix4Dmodel license include?

Pix4D Products  
Desktop - Pix4Dmodel (unlimited one device) Processing, visualization, editing, export
Cloud - Pix4Dmodel (unlimited) Processing, visualization, export, web sharing
App - Pix4Dcapture (unlimited) Flight planning, image acquisition
Cloud specifics  
Generated outputs 3D Textured Mesh
Downloadable Files

Input Images
Export to Pix4D Desktop
3D Textured Mesh (.obj, .fbx)
Quality Report
Processing log

Annotations

Add markers and labels to identify elements
Measure distances and surfaces in your 3D model

Desktop specifics  
Processing Available templates: 3D Models (Rapid/Low Res)
Available steps: 1. Initial Processing, 2. Point Cloud and Mesh
rayCloud features Processing area
Image annotation
Point cloud editor (classification tool)
Flythrough video
Polyline and surface measurement (no export)
File exports Quality Report (.pdf)
3D Textured Mesh (.dxf, .fbx, .obj, .ply, 3D .pdf, .osgb, .slpk)
Video Animation (.avi, .mkv, .mp4)

 

 

How can I get assistance?

Pix4D Support Site provides a wealth of information with many articles in the knowledge base.
Pix4D Forum allows to share experience and interact with the Support Team.
Parrot Customer Support also gives access to a personalized help.

How should I proceed to start? What is the workflow?

The general workflow that is suggested consists in the following steps:

1. Plan and fly a mission with Bebop 2 and Pix4Dcapture app.
2. Transfer the images from the drone to the device and upload the mission to the cloud.
3. Process on the cloud with default settings.
4. Share, publish, export to 3rd party software or 3D print your 3D model.

 

How to fly with Pix4Dcapture app?

The Getting Started provides the basis for understanding the app: 202557269 (Android), 204692015 (iOS). It is recommended to carefully read the instructions before going to the field and starting the first flight. The app connects to Bebop 2 with or without a remote controller. For more information: 213226623.

Different types of mission can be selected depending on the purpose of the mapping. For more information:209960726. For real estate applications, a simple grid mission combined with a circular mission would be a good option.

 

How to transfer the images to Pix4Dmodel cloud?

There are three ways to upload the images to the cloud: 

1. Through Pix4Dcapture: Synchronizing consists in generating the Pix4D project file (.p4d) on the mobile device and transferring the images from the drone. This can be done on the field right after the flight or later in the office: 204716225 (Android), 204057579 (iOS). Then the mission can be uploaded to the cloud when Internet connection is available.
2. Directly on Pix4Dmodel cloud: 215858503.
3. Through Pix4Dmodel desktop: 202558589Make sure to check the box Start Processing.

How to process on Pix4Dmodel cloud?

Once the images are uploaded to the cloud, the processing starts automatically on Pix4D servers and a notification is send by email to confirm the status of the project. When the processing is completed, a second email is sent with the direct link to access the project.

The following instructions explain how to share the model and download the inputs or outputs:

1. Go to Pix4D cloud.
2. Select the solution Pix4Dmodel.
3. In the 3D Models list, click the mission’s name.
4. Click Share to send the link of the 3D mesh viewer.
5. Click Back to 3D Models to download files from the 3D Models list.

5.1. Click Download > Input to save both the images and .p4d file to desktop.
5.2. Click
Download > Mesh or Quality Report to save the outputs to desktop.

 
Important: It is possible to edit the model and access additional features in Pix4Dmodel desktop. After editing the model, it can be uploaded to the cloud to process and share the results: 202558589. Make sure to check the box Start Processing. For advanced users it is possible to edit the .p4d file of the project to modify features.

 

How to process with Pix4Dmodel desktop?

A minimum hardware configuration is required to successfully process projects on a computer. For more information: 202557289.

After downloading the .zip input file from the cloud, proceed as follows. A Bebop 2 demo project is available for download if needed: 209620783.

1. Install and open Pix4D desktop: 202557299.
2. In the Login window, enter the license credentials and click Login.
3. Select the license Pix4Dmodel and click OK.
4. Click Project > Open Project... and select the .p4d that was downloaded from the cloud to open the project.
5. (optional) Create the project from scratch with the 3D Models processing template using the images acquired with Pix4Dcapture: 202557369
6. On the menu bar, click View > Processing. In the Processing bar at the bottom, check the box 1. Initial Processing and click Start.
7. Analyze the calibration results: 217145966.
8. Use specific tools and customize the settings to achieve the best 3D model: 217145966.
9. On the menu bar, click View > Processing. In the Processing bar at the bottom, check the box 2. Point Cloud and Mesh and click Start.
10. Improve the results and use rayCloud features: 217145966.
11. Export files and outputs. The 3D Textured Mesh is 3D printable and compatible with several third-party programs. More information in this article 202558499 and in section Share, publish, export to 3rd party software or 3D print your 3D model.

 
Information:
  • For images taken with the drone Bebop 2, the sky is automatically removed during step 1. Initial Processing. This is done with the Automatic Sky Masking option, which is selected by default with such images. For more information: 205327965.
  • If images were acquired with different angles relative to the ground (e.g. aerial oblique and nadir, or aerial and terrestrial images). Then, the recommended workflow is to run step 1. Initial Processing for each set of images separately before merging them. For more information: 202558529.

 

How to use advanced desktop features?

After running step 1. Initial Processing

Improve the calibration

A Quality Report is exported to summarize the first results and provide a detailed analysis on the calibration of the images. It is located here: ...\project_name\1_initial\report\Project_name_report.pdf. For more information: 202558689.

If the processing fails, most common causes are related to the image quality, the overlap or the camera model. For more information: 203832269. To test the reliability of the reconstruction, checking the reprojection error is recommended: 202559369. It might be required to add Manual Tie Points (MTPs): 202560349.

Additional features

The following features have no impact on step 1. Initial Processing but affect the computation during step 2. Point Cloud and Mesh and the subsequent outputs.

  • Processing area: By default, a processing area is automatically created in the .p4d file after acquiring images with Pix4Dcapture app. However, the project boundaries (planar but also minimum and maximum altitude) can be adjusted in the rayCloud by editing the processing area or drawing a new one. For more information: 202560179.
  • Annotation tool: Another tool to optimize the results generated during step 2. Point Cloud and Mesh is to annotate the images in order to discard some parts of their content like sky or undesirable repetitive patterns. For more information: 202560549.
  • Processing options: It is recommended to keep the default options of the 3D Models template, but the settings for generating the point cloud and the mesh, as well as the export formats, can be changed if necessary. For more information: 208194103.

After running step 2. 

Edit and improve the mesh

  • Edit Densified Point cloud: The points can be assigned to different groups. The point cloud editor is useful to remove undesired points e.g. due to noise, vegetation or from the background. For more information: 202560499. The editing affects the visualization of the point cloud. However, since the mesh is derived from the point cloud, it is possible to (re-)generate the mesh so that the deleted points are discarded. For more information: 202560669.
  • Create surfaces to improve the mesh: To improve the mesh and especially the visual aspect of flat objects like building facades. For more information: 211083803.

2D Measurements

  • Polylines and surfaces can be created in the rayCloud to perform 2D measurements. For more information: 202560739.

Video creation tool

  • Video animation trajectory: Besides exporting the 3D Textured Mesh, a flythrough video made from different views of the point cloud or mesh displayed in the rayCloud can be generated and exported. For more information: 202560299.

 

Share, publish, export to 3rd party software or 3D print your 3D model

This section describes how to share, publish, export to 3rd party software or 3D print your 3D model (mesh).

Outputs

The list of outputs available in Pix4Dmodel cloud and Pix4Dmodel desktop

How to share

Pix4Dmodel cloud: Click the Share button  and an external link and an HTML embedded link to the project will be created. More information in section How to process on Pix4Dmodel cloud. Note: this enables to share a 3D view of the project. 

Pix4Dmodel desktop: In the desktop version it is possible to share the 3D model as .dxf, .fbx, .obj, .ply, 3D .pdf, .osgb and .slpk: 202560669. A Video Animation in .avi, .mkv and .mp4 can also be shared, the location of the result files is user defined: 202560299 

Compatibility with 3rd party software

The outputs of Pix4Dmodel cloud and desktop are compatible with many 3rd party softwares, such as:

For the full output compatibility list: 202558499.

How to 3D print your 3D model

Outputs from Pix4Dmodel cloud and desktop can be printed in 3D: 202559649

 

Was this article helpful?
0 out of 0 found this helpful


Powered by Zendesk