(Android) How to change default app when connecting to the drone

A specific app could be selected to perform some actions on an Android device. When using Pix4Dcapture, a pop-up appears when the device is trying to establish the connection with the drone. If another app was used in the past to fly the drone and the user tapped Always, there is a conflict and Pix4Dcapture will not be able to connect to the drone.

 

To solve this problem, proceed as follows:

1. Open the Settings app of the Android device.
2. Scroll the list and tap Apps or Applications.
3. (optional) On certain devices like Samsung, tap Application Manager.
4. Scroll the list and select the app to be removed as default.
5. Tap CLEAR DEFAULTS. For some devices, it is needed to first tap Open by default to see that option.

Was this article helpful?
8 out of 20 found this helpful

Article feedback (for troubleshooting, post here)

5 comments

  • Pedro Marçal

    Ola,

    desde que actualizei o parrot anafi, agora quando tento entrar no pix4dcapture, ele sai logo do programa e nao passa disto, ja segui varios passo e nao entendo, alguma ideia sff...

  • Kapil (Pix4D)

    The behavior you are describing can’t be replicated on our side and has not been reported to us so far. I would suggest you go through all the basic checks and troubleshooting steps as it will solve most of the issues that can be encountered if properly followed.

    Edited by Kapil (Pix4D)
  • bsyrt immas

    Since the moment I upgraded the drone to firmware 1.7.3 and the controller to firmware 1.7.0, it didnt work anymore with Pix4D capture.

    There are other reports in the same sense:

    https://community.pix4d.com/t/pix4dcapture-crashes-with-parrot-anafi-firmware-v1-7-in-android/15016/4

    Parrot Anafi Thermal + Android phone (Redmi Note 8)

  • bsyrt immas

    Any alternative to Pix4d??

    Edited by bsyrt immas
  • Kapil (Pix4D)

    Hello,

    The Parrot Anafi won't work with the recent firmware update of 1.7.3. We will release a new version for Pix4Dcapture android within a few weeks and it should work with that version.

    For now, the only option is not updating the firmware to 1.7 or using the iOS version of the Pix4Dcapture app.

    Regards,

Please sign in to leave a comment.