The takeoff window displays a checklist that has to be validated before the drone can take off.
If an item of the checklist is not validated it can have 2 different status:
Item is currently being checked
Check failed
Item is currently being checked
The item is being verified. After some time, it will be validated or the check fails.
Check failed
Depending the item of the checklist, a failure can have different causes and different solutions:
Connected to drone ⤴ |
Cause The App is not connected to the drone through Wi-Fi.
Solutions 1. Check that the Wi-Fi connection is activated from the device. 2. Check that the range extender is turned on. 3. Restart the App and the drone if you don't find the problem.
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Autopilot switch position⤴ |
Cause The switch is not in the correct position to allow automatic piloting or there is not enough GPS signal.
Solutions 1. Check that the Drone GPS satellites check is validated. 2. Flip the switch of the remote controller to the correct position. 3. Wait a few seconds.
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Drone close to grid ⤴ |
Cause The drone is too far away from the grid (more than 250m).
Solution Bring the drone close to the grid. It has to be maximum 250m away from the center of the grid.
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Drone SD card ⤴ |
Cause There is not enough space on the SD card.
Solutions 1. Check that the SD card is not full. 2. If the SD card is not full, wait up to 1 minute until the status is refreshed.
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Battery levels sufficient ⤴ |
Cause The drone or range extender battery level is not sufficient.
Solutions 1. Verify that the drone's battery is charged (at least 20%). 2. Verify that the range extender's battery is charged (at least 20%).
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Ground station connected ⤴ |
If using the Phantom 2 Vision+:
Cause The App is not connected to the drone.
Solution Restart the drone and the device. Ensure that the device is connected to Internet when restarting it.
If using the Phantom 3 Advanced/Professional or the Inspire 1:
Cause
- The App is not connected to the drone.
- The drone is not flying.
- The drone firmware is not updated.
Solutions
- Restart the drone and the device. Ensure that the device is connected to Internet when restarting it.
- Make the drone take off.
- Update the drone firmware.
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Drone GPS satellites ⤴ |
Cause The drone is connected to less than 6 GPS satellites.
Solutions
- Wait a few seconds.
- Try to restart the drone, the remote controller, and the app.
- If possible, take off manually. The drone will detect more satellites if it is above the surrounding obstacles such as buildings.
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Home point set ⤴ |
Cause The drone is not connected to enough GPS satellites to retrieve its position.
Solution Verify that the Drone GPS satellites check is validated.
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Mission is within range ⤴ |
Cause The drone's home point is not known or the home point is too far (more than 150m from the center of the grid) from the mission.
Solution Take off manually to set the home point. Verify that your mission is not too far from the drone's current location.
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Phone storage ⤴ |
Cause There is not enough free storage on your device.
Solution Free some space on your device.
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Drone is flying⤴ |
Cause The drone is not flying.
Solution 1. Start the rotors. 2. Make the drone take off.
The drone doesn't have to be flying very high. 1 or 2 meters is enough.
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Mission upload⤴ |
Cause The mission has not been uploaded to the drone or the mission was rejected by the drone.
Solution 1. Wait. There may be other takeoff items which must pass before the mission can upload, or it may take a while for a long mission to be generated and uploaded. 2. Make sure the connection with the drone is strong. 3. Restart your drone and start again.
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Calibration⤴ |
Cause The drone requires calibration.
Solution 1. Launch DJI GO. 2. Follow the instructions to calibrate. 3. Relaunch Pix4Dcapture.
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Thanks for these tips.
I find a major problem, is that there is no on screen feedback to what might be causing take off issues.
Couple of other things to check:
Ensure that the geolock is refreshed in the DJI app
Remove and reinstall the Drone battery to force a reboot not just tun off and on.
Hi Mark,
Thank you for your relevant feedback. It would be indeed great for the user to be guided directly when experiencing a takeoff item check fail. I shared your feedback with the developer's team.
Did you have the chance to see a change in the takeoff checklist after having removed and reinstalled the drone battery at some point?
Best,
The take off check list appeared to be the same as always. I did not get to this screen before I removed the battery, only when I reinstalled it.
Hello,
my name is Stergiou Efthimios from Greece. I recentry bought DJI Mavic Pro2 Drone and have problem taking off. Fail: Drone storage status unknown. Have restored Factory data reinstalled the CTRL+DJI App and checked that the SD card has enough free space (is almost empty). Could you please help me?
The behavior you are describing can’t be replicated on our side and has not been reported to us so far. I would suggest you go through all the basic checks and troubleshooting steps as it will solve most of the issues that can be encountered if properly followed. I would also suggest you change the SD card and see if that helps to solve your issue.
Regards,