Error: "There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor"

Error

"There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor".

 

Description

When installing the software you may receive the following message:

 installer_information.png

 

Cause

This error may come from different reasons:

  • The computer does not meet the minimum requirements for Pix4Dmapper.
  • Windows is not updated.
  • Not full access to the folder: C:\Users\<username>\AppData\Local\Microsoft\Windows\ or C:\Users\<username>\AppData\Local\Temp\

 

Solution

To troubleshoot the issue follow the items below in order, after each item, restart the computer and try the installation again, if still fails, proceed to the next item listed:

1. Confirm that the computer where Pix4Dmapper is being installed has the minimum requirements: 202557289.

2. Make sure that is Windows updated.

3. Change the permissions to full access to:

C:\Users\<username>\AppData\Local\Microsoft\Windows\ or C:\Users\<username>\AppData\Local\Temp\

1. Make sure that the hidden files and folders are shown in Windows:

1.1. Open the Control Panel in Windows.
1.2. Click on Folder Options to open the Folder Options pop-up.
1.3. In the tab View under the section Advanced settings, click Show hidden files, folders, and drives.
1.4. Click OK.

2. Open Windows Explorer and locate the folder mentioned above.
3. Right click on the folder, the Local Properties pop up window will appear.
4. Select the tab Security.
5. Click Edit,  the Permissions for Local pop up window will open.
6. On Group or user names, select the desired user.
7. Ensure that the Allow check box for Full control is activated, else activate it.
8. On the Permissions for Local pop up window, click OK (if no changes were made) or Apply (if changes were made).
9. On the Local Properties pop up window, click OK (if no changes were made) or Apply (if changes were made).

4. If the above suggestions do not solve the issue, send the installation log file to support@pix4d.com. To generate the installation log file:

    1. Find out the path of the MSI file, for example: C:\Users\John\Downloads\Pix4Dmapper.msi
    2. Decide the path of the log, for example: C:\Users\John\Documents\pix4d.log
    3. Open a command shell: click on start and type cmd.exe and press enter.
    4. In the command shell window type the following instructions and make sure to use the correct path to the MSI file and the log file:
      msiexec /i "C:\Users\John\Downloads\Pix4Dmapper.msi" /L*V "C:\Users\John\Documents\pix4d.log"

 

Disclaimer: Pix4D publishes this information as a courtesy to its customers. Because this information may not be accurate, Pix4D makes no warranty of any kind, expressed or implied, with respect to its validity.

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