How to create and process a Tetracam dataset

There are multiple versions of Tetracam cameras:

 ADCADC AirADC LiteADC MicroADC SnapMiniMCA 4MiniMCA 6 MiniMCA 12
  Single Single Single Single  Single RIG 4 RIG 6 RIG 12
MP 3.2 3.2 3.2 3.2 1.3 4 x 1.3 6 x 1.3 12 x 1.3

focal length
[mm]

8 (variable) 8 (variable) 8 (variable) 8.43 fixed lens 8.43 fixed lens 9.6 fixed lens 9.6 fixed lens 9.6 fixed lens
Bands Green, Red, NIR Green, Red, NIR Green, Red, NIR Green, Red, NIR  Green, Red, NIR       

pixel size [μm]

3.2 3.2 3.2 3.2 5.0      

 

The workflow to follow for processing tetracam projects:  

Workflow #1 for ADC, ADC Air, ADC Lite, ADC Micro, ADC Snap
Workflow #2 for MiniMCA 4,6,12

 
Important: For more information about how to use PixelWrench2 to correctly prepare the dataset, before importing it into Pix4Dmapper, contact Tetracam.
 
Tip: The recommended camera is the ADC Snap. It provides optimal results. The other models suffer from slow rolling shutter, and should be used only on extremely stable and slow moving UAV/aircraft platform.

 


Workflow 1 (for ADC, ADC Air, ADC Lite, ADC Micro, ADC Snap)

image06.png

 

1. Open PixelWrench2.
2. Click View > Launch GPS Distiller.
3. Click Distill file, and select the flightlog that was on the SD card. Save the GPS file.

image13.png

4. IMPORTANT
Perform sensor radiometric calibration (using the camera PCF file), as well as vignetting correction. These are done in the Matrix tab of IndexTools. If these steps are not done, the radiometric values may consequently be less accurate and affect reflectance values and the generation of indices.
5. Click View > IndexTools
6. In the IndexTools widget, click the Batch tab.
7. Ensure that:

    • The output format is TIF.
    • The distortion is unchecked.
    • Save Originals is checked.

image10.png

8. Click Run Folder Batch, select the folder with RAW images, select the output folder.
9. Open Pix4Dmapper: Project > New project...
10. Type project name Click Next.
11. Add the images. Click Next.
12. In the section Image Geolocation, under Geolocation and Orientation, click From file...:

1. Select Tetracam as File Format.
2. Select the file .GPS generated at step 3

13. In the section Selected Camera Model, click Edit...
Ensure that:

    • The Camera Model Name contains the word Tetracam, and that Camera Model Parameters are not empty or 0.
    • The bands are NIR, Red, Green.

To perform changes, click Edit, and then OK.

14. Select the Agriculture Template and finish the creation of the new project.

15. Click Process > Local Processing:

      • Click Options...
      • Make sure that the Calibration Method Alternative is checked (if there are good images coordinates): 205327965.
      • Set Internal Parameters Optimization: Leading and  External Parameters OptimizationAll

Click OK and process. If processing fails, update Internal Parameters Optimization: None and reprocess Step 1.

 

 

16. Open the Index Calculator to work with the Reflectance Map and Index Maps like the NDVI.
For more information about the Index Calculator: 202558289.

 

Workflow 2 (for MiniMCA4,6,12)

 

image06.png

 

  1. Open PixelWrench2. Select View > Launch GPS distiller.

  2. Press Distill file, and select the flightlog that was on the SD card. Save the GPS file.

  3. Open PixelWrench 2. Select View > Index tools

  4. If You have the ILS sensor (and you should), in the EditTools widget
    Select the Tab "ILS"
    Load the corresponding ISC file
    Check "do not write Sensor image to TIF"
    Check "save tifs as reflectance values"

  5. Important
    Perform sensor radiometric calibration (using the camera PCF/MCA file), as well as vignetting correction. These are done in the Matrix tab of the indextools. If these steps are not done, the radiometric values will likely be less accurate and impact the reflectance and generation of indices.
  6. In the EditTools widget, select the Tab “MCA”
    Click on OpenMCA and open your MCA file (check manual to set correct value for the MCA file)
    Make sure to use a MCA file that contains X,Y, rotation and scaling compensation

    Click on Multipage Tiffs

    • Select input directory
    • Select output directory


    image11.png

  7. Open Pix4Dmapper. Go to Project > Create new project.
  8. Enter project name, and select project's workspace directory.

  9. Add the images, click next.
  10. Select the same MCA file as was selected in PixelWrench, when prompted.

    You should now see a different camera model for each band

    Capture2.JPG

  11. Click on the button. Geolocation ->From file..
    Select Tetracam as File Format.
    Select the file .GPS generated at step 2

  12. If you click on Edit… in the camera model, make sure that the camera model name contains Tetracam, and that all fields are not empty or set to 0.

    To perform any change, select Edit.
  13. Finish the creation project wizard.
    Click on Process > Local Processing.
    Click on Options.

    Ensure that Alternative is checked.

    Change Optimization settings to “Optimize externals and leading internals”.
    Click ok and process.

    If processing fail, try with “optimize externals only”

    If processing still fails, try with “feature scale 2"
  14. Start processing, and then go to Index calculator. First generate the reflectance map at a given resolution, then select or introduce a formula such as NDVI. Finally add anchors in the histogram to visualize the colored map NDVI.

    If the NDVI formula is not available, click on Index List button. In the index list widget, click on Add to go to the formula editor. In the formula editor widget, click on the band that is the closest to 800nm (typically 780nm), press the minus button, then the band closest to 680nm (typically 670nm), then the division sign, open parenthesis, the closest to 800nm, the plus sign, the closest to 680nm and close the parenthesis. The formula should like this:

    w780 - w670 / (w780 + w670)

    validate the formula by pressing OK, then rename the formula to NDVI in the Index list and validate by pressing OK. Back in the Index calculator, make sure that this new formula is selected, and press Generate to compute the index.

  15. For more information about the index calculator: 202558289




Was this article helpful?
0 out of 0 found this helpful