Applications with Global Mapper

   

Merge of .tif orthomosaic / DSM / DTM files

When the area of interest is very big and the amount of data large, multiple Pix4Dmapper projects can be created for one area. To merge .tif files that are generated from the multiple projects, use an external GIS software like Global Mapper.

 
Important: The projects must be georeferenced with GCPs in order to have the same accurate georeference. For more information about the use of GCPs: Step 1. Before Starting a Project > 4. Getting GCPs on the field or through other sources (optional but recommended).

In order to merge the different GeoTIFF orthomosaic files in Global Mapper:

1. On the menu bar, click File > Create New Map Catalog.
2. In the window Save As, choose where the new Global Mapper Project will be saved and click Save.
3. In the window Modify Map Catalog, click Add files to choose the files to merge.
4. A message appears about how many maps have been added to the map catalog. Click OK.
5. In the window Modify Map Catalog, click OK.

modify_map_catalog_h_2.jpg

6. On the menu bar, click File > Export > Export Raster Image Format.
7. On the pop-up Select Export Format, select GeoTIFF and click OK.
8. In the window GeoTIFF Export Options, select the following options:

geotiff_export_options_h.jpg

 
Important: Choose the 24-bit RGB (Full Color, May Create Large Files) option if the images are 24-bit RGB.

Contour lines from DSM / DTM

Pix4Dmapper can generate contour lines. For more information: Menu Process > Generate Contour Lines. However, it is also possible to extract contour lines using the DSM or DTM generated by Pix4Dmapper.

1. Drag and drop the .tif file onto the main view of Global Mapper.
2. On the menu bar, click Analysis > Generate contours...
3. In the window Contour Generation Options, check the settings and click OK.

To improve the visual aspect, it is possible to delete small lines and to smooth the contour lines.

Delete small lines

Depending on the area and its elevation, some tiny contours might be generated (see picture below).

globalmapper_tiny_contours.png

1. On the menu bar, click Edit > Select All Features with Digitizer Tool.
2. After all features are selected automatically, click the Digitizer Tool .
3. Right click on the main view and click Attribute/Style Functions > Add/Update the Measure Attributes of selected Feature(s).
4. On the menu bar, click Search > Search by Attributes, Name and Description.
5. In the window Search Vector Data, in the section Searh Criteria, select LENGTH from the drop-down list under Attributre/Item. Enter a Compare Value. All the contours that have length below this value will be selected.
6. Click Delete Selected.

globalmapper_search_vector_data.PNG

Smooth contour lines

Contour lines are often sharp and need to be smoothed.

1. On the menu bar, click Edit.
2. Click Select All Features with Digitizer Tool.
3. After all features are selected automatically, click ic_globalmapper_pencil_tool.png.
4. Right-click on the main view and click Move/Reshape feature(s) > SMOOTH - Smooth Selected Line/Area Feature(s).

globalmapper_smooth_lines.png

 
Note: If more smoothing is needed, follow the above process (step 1-5) again as many times as needed in order to obtain the needed smoothing.

Conversion of DSM / DTM to DEM format

The USGS DEM standard is a geospatial file format for storing a raster-based digital elevation model. Pix4Dmapper generates the raster DSM / DTM as GeoTIFF. To convert it to DEM:

1. Drag and drop the GeoTIFF file onto the main view of Global Mapper.
2. From the menu bar, click File > Export > Export Elevation Grid Format.
3. Select the DEM format.

For more information: Global Mapper help.

Vertical offset of contour lines

1. Open the contour lines file in Global Mapper.
2. On the menu bar, click File > Export > Export Vector Format and select XYZ (Simple ASCII) Text File.
3. In the window ASCII Export Options, check the box Export Elevations for Each Vertex, and click OK.
4. Open a new Global Mapper project (workspace).
5. On the menu bar, click File > Open Generic ASCII Text File(s).
6. In the window that opens, select the file previously exported (step 3).
7. In the window Generic ASCII Text File Import Options, click Select Coordinate Offset/Scale and check the box Point, Line, and Area Features.

globalmapper_offset_contours.png

8. In the window Select Coordinate Offset/Scale, set the Z vertical offset value (in this example 30 meters) and click OK.

globalmapper_z_offset.png

The contour lines now have been vertically offset. To change their labels to the new altitude values:

1. On the menu bar, click Tools > Control Center.
2. Right-click on the contour lines layer.
3. Click CALC ATTR - Calculate/Copy Attribute value.
4. In the window Attribute Calculation Setup, type the new attribute name.
5. In the field Source Attribute, select Elevation.
6. In the field Operation, select Add.
7. In the field Used Fixed Value, set the offset (in this example 30 meters).

globalmapper_attribute_calculation.png

8. Click Calculate.
9. On the menu bar, click Tools > Control Center.
10. Select the contour lines layer and click Options...
11. In the window Vector Options, select Use Selected Attribute Value for Name option and from the drop down list, select the new attribute previously created (step 4).
12. Check the box Display Labels for Layer if any Shown.

globalmapper_vector_options.png

 

Disclaimer: Pix4D publishes this information as a courtesy to its customers. Pix4D makes no warranty of any kind, expressed or implied, with respect to the content's validity or accuracy.

Was this article helpful?
2 out of 2 found this helpful

Article feedback (for troubleshooting, post here)

0 comments

Please sign in to leave a comment.