How to upload project files from Desktop to Cloud

1. On the menu bar, click View > Processing.
2. On the processing bar at the bottom, check the three boxes for all steps. For more information: Menu View > Processing .

 
Information: Processing on the Cloud will start with Step 1 if Step 1 has not been processed on the Cloud yet. If some edits need to be done on the point cloud, after the processing on the Cloud has finished, download the point cloud and open it locally to edit it, then replace the point cloud previously generated on the cloud with the edited one from the cloud interface: click FILES and in the corresponding Point Cloud box, REPLACE FILE.

all_steps_enabled.png

3. On the menu bar, click Project > Upload Project Files...

upload_project_files.png

4. In the File Upload window, check the box Start Processing.


5. Ensure that the preferred solution is selected. Click here below the Progress bar. For more information: How to select a preferred solution
6. Click Upload.
7. An email is sent shortly to inform of the project status.

 
Tip: You can easily share your project on Pix4D Cloud with anyone.
 
Important: If you upload your project for technical support, let your Pix4D Support point of contact know when your project's name when it is available on Pix4D Cloud.

 

Pix4D cares about your privacy and does not claim any ownership of your data. Find more information in our Terms of use.

Was this article helpful?
13 out of 17 found this helpful

Article feedback (for troubleshooting, post here)

13 comments

  • ROHIT SINGH

    I do exactly as it is mentioned above but my project went to Pix4dmodel not on Pix4dmapper, i want to upload my project to Pix4dmapper, how will i do it????

    Please answer.

  • Alice (Pix4D)

    Thanks Rohit for your feedback. We have updated the article to add this information (see Step 5). 

  • Phosai Amnat

    after step 6. the progress still at 0% and can not upload anything.

    and I got this messages 

    "[Error]: Error e9034: Problem uploading item to the cloud."

    please help.

  • Holden (Pix4D)

    Hi Phosai. Can you create a project from scratch on the cloud by uploading the images directly? This will test if it is a network issue. If you can then please recreate the project from scratch to see if that allows you to upload. If it still doesn't work then please consider opening a support request on the home screen linked below. Please attach the log file and .p4d file so we can take a closer look. 

    https://support.pix4d.com/hc/en-us 

  • Phosai Amnat

    Dear Holden

    i can create a project&upload  on the cloud directly, it works fine.

    but i think maybe my problem is internet connection issues because i try a new connection today the progress increase to 30% (and fail ) so i think the internet not good enough.

    thank you

  • Alice (Pix4D)

    Other conditions might cause the e9034 error:

    - Special characters in the image pathname. In this case, please remove the special character, open the p4d locally, save the project re-upload to the Cloud.

    - A firewall is blocking the upload. In this case, deactivate it.

    - Try to connect to the Internet with a Lan cable directly, rather than with the wifi if possible.

    Let us know how it goes.

  • Emmanuel Durand

    Hello,

    I am doing all the processing on the Desktop. Then I am trying to export all project files the Cloud "as is". I do not want to "Start processing" on the cloud because the job has been done already on my laptop and I don't want to "consume" my credit of 2,500 pictures on the cloud. (So that I uncheck the "start processing" box).

    I click "upload"... Initially the upload could not complete, had to do again and again. Ultimately I managed to complete the upload : )

    But as a result, I discover that only the pictures have been uploaded. All the rest is empty : (

    What does that mean? Why cant we export the Orthomosaic etc..

  • Blaž (Pix4D)

    Hi Emmanuel,

    It is possible to only upload the results generated in Pix4Dmapper without reprocessing the project. To do so, I recommend checking the instructions in How to upload results and outputs to the cloud article. 

    Click UPLOAD FILE(S) under the output to be uploaded, and browse for the directory to select the file. Alternatively, it is possible to drag and drop the file(s) onto the respective output section

    Best,

  • Emmanuel Durand

    Hello Thanks for the answer,

    OK now I got it and understand that

    - The "Upload" Project and Image files from Desktop will NOT export the .las and all automatically, will export only the images : (

    - The Upload of other files than images is limited to only Orthomosaic, DSM, Point Cloud and Mesh. For example, the report cannot be exported from Desktop to Cloud, true?

     

    OK now I did the manual upload Ortho-DSM-PointCloud-MeshObj and see

    Unfortunately, I am not able to open the project and please see

    https://cloud.pix4d.com/pro/project/458548/map?shareToken=fde5213f-e45d-4c94-adb2-10206088937a

    ??

    Do I have to wait for some time after the upload to visualize say, the Orthomosaic?

    Best regards,

    Emmanuel

     

  • Alice (Pix4D)

    Hi Emmanuel,

    Uploading the Project Files from the desktop application without starting processing will upload to the Cloud the images and the project (.p4d) file only. This option is available for users that want to start the processing at a later stage.

    If you want to upload only the results, please create a new project from the Cloud page and upload the results from the interface, as explained by Blaž.

    To answer your second question, the Quality Report, together with other additional outputs, are generated only when the project is processed on the Cloud. To check the list of downloadables after processing, see the article How to download results from the cloud. If the processing is not run on the Cloud, the results that can be uploaded are the DSM, the orthomosaic, the Point Cloud and the Mesh, as you said.

    I will take care of making the procedure of downloading/uploading clearer in our articles. If there is still something which is not explained well from your point of view, feel free to let me know so that we can improve it.

    Best,

  • Emmanuel Durand

    Hello Alice,

    Thank you very much for your answers, and we are really progressing a lot.

    Please see

    https://cloud.pix4d.com/pro/project/460262/map?shareToken=0ff2e134-4567-4e34-908d-5ebc291a154e

    Comments:

    • I have been following all the steps, and everything does import nicely (ortho, dsm, cloud and mesh)
    • However and for some reason ?? the cloud and mesh layers are not "stable": immediately after download the mesh is visible, but we cannot make measurement (it's like no point cloud behind). Then if we reload the point cloud, it will appear but there is no way to have the mesh again.
      All in all, t's like the imported mesh and point cloud cannot cohabitate (??)
    • For Ortho and DSM (2D), all is normal
    • On projects that have been computed over the cloud (and not imported), everything is OK (DSM+Ortho+Cloud+Mesh)

    Best regards,

    Emmanuel

  • Alice (Pix4D)

    Hello Emmanuel,

    I see your problem. I forgot to mention that the Mesh generated by Pix4Dmapper is not georeferenced, while the Point Cloud is. Since they are placed in the same viewer, it looks like they cannot cohabitate.

    But if you replace the Mesh files uploading the .obj, .jpg, .mtl and .xyz files (you can find this last one in the \1_initial\params folder) in the 3D mesh box, the uploaded mesh should be properly georeferenced and aligned with your point cloud. It is important that all the 4 files are uploaded at the same time or at least the offset file is uploaded first and the 3 files for the mesh are uploaded later, so I suggest that you copy them in a single folder and then drag and drop them in the project's files section for uploading.

    Let me know if all works then.

    Cheers

  • Emmanuel Durand

    Thanks Alice,

    All good and it does work : )

    Now I can re-work my project and then re-export them. Amazing!

    Thanks again!

Please sign in to leave a comment.