Menu Project > Image Properties Editor... > Selected Camera Model > Edit Camera Model

IndexInterface > Menu Project  > Image Properties Editor... > Selected Camera Model  Previous  |  Next 

 

 
Access: On the Menu bar, click on Project > Image Properties Editor..., the Image Properties Editor window appears, in the Selected Camera Model section, click Edit... 
 
Access via the New Project wizard: When creating a new project, the Image Properties window appears after loading the images, in the Selected Camera Model section, click Edit...

The Edit Camera Model window is used to define or edit the camera model.

The camera model can be set to perspective or fisheye lens. 

There are 3 sections:

 and 3 action buttons:

  • OK: Confirms/applies the changes:
    • Uses the camera model selected in the Camera Model section if saved into the camera model database.
    • Uses the camera model name and parameters displayed in the Camera Model Parameters section if selected while editing or creating a new camera model. The currently displayed camera parameters are not saved into the camera model database but they are saved only in the project .p4d file.
  • Cancel: Does not save the changes.
  • Help: Opens the Pix4Dmapper help.


Camera Model

The following items are displayed:

  • EXIF ID: Displays the current EXIF ID (CameraModel_ FocalLength_ResolutionWidthxResolutionHeight) of the camera. No user intervention is possible.
       
  • Camera Model Name: Displays the currently selected camera model. The corresponding drop-down list allows the user to select another known camera model with the same image width and height.

Beside on the left of the selected camera model name, an icon appears that describes the source of the camera model:

database.png: Camera model taken from the internal camera model database.
pencil.png: Camera model taken from the internal camera model database with some user-edited values.
user.png: Camera model taken from the user camera model database.
camera.png: Camera model taken from the image EXIF data when the camera model does not exist in the internal or the user database and there is valid information in the EXIF data.
document.png: Camera model taken from the .p4d file when a .p4d file is created and its camera model does not exist in the internal or the user camera database.

 
Note: There are 2 camera databases: internal camera database (with the cameras and values from Pix4Dmapper), and user camera database (with the cameras added or modified by the user).
  • The internal camera database cannot be edited, modified or deleted.
  • The user camera database can be:
    • Edited Menu Project > Image Properties Editor... > Selected Camera Model > Edit Camera Model.
    • Cleared, imported or exported from Help > Settings..., under the tab Camera database.

Click the drop-down list to display the available camera models. The drop-down list only displays camera models with the same image width and height as the one detected in the EXIF ID. The drop-down list displays camera models using perspective lenses if Perspective Lens (Camera Model Parameters section) is selected and it displays camera models using fisheye lenses if Fisheye Lens (Camera Model Parameters section) is selected.

 
Note: No information is displayed if no camera model exists with the same image width and height.

The following buttons are displayed:

  • Edit: Edit the Camera Model Bands and/or the Camera Model Parameters for the selected camera model. To edit the camera parameters: How to use the Editing Camera Model Options.
  • New: Create a new camera model. To create a new camera model: How to use the Editing Camera Model Options.
  • Restore: It is displayed only for camera models that exist in the internal camera database and have been edited by the user and stored in the user camera database. It removes the camera model from the pencil.png user database and restores the parameters from the database.png internal database.
  • Save to DB: Visible when clicking on Edit or New. Save the camera model in the user camera model database.
 
Note:
  • When editing database.png, and saving to DB, it changes to pencil.png
  • When editing pencil.png, and saving to DB, it creates pencil.png
  • When editing user.png, and saving to DB, it creates user.png
  • When editing document.png, and saving to DB, it creates user.png
  • When editing database.png or pencil.png or user.png or document.png, and clicking in OK without saving to DB, it creates document.png
  • When creating new and Saving to DB, it creates user.png
  • When creating new and clicking in OK without saving to DB, it creates document.png
  • Cancel edit: Visible when clicking on Edit or New. Cancel the editing or creating of a new camera model.

 

Camera Model Bands


The section contains 2 items:

  • Bands: Displays the band configuration selected for the project. If the band configuration is in the EXIF, and it is one of the bands listed below, it is selected automatically. It allows the user to change the band configuration when more bands have been added to the camera model.

  • Edit...: Opens the Edit Camera Model Band Configurations pop-up:

     
    Access: It is enabled if Edit or New has been selected in the Camera Model section.
     
    Allows to add/edit/remove Band configurations.

    There is one section:

    • Band configurations table:

      Each row displays information for one band configuration: 

      • Default: Displays which band configuration is selected by default when using the selected Camera Model.
      • Bands Number: Number of bands for the Camera Model.
      • Name: Name of the band configuration, double click on the cell to edit the name.

     and the action buttons:

    • Add..: Opens the pop-up band configuration window to add a new band configuration.

      By default the values of the RGB band configuration appear:

      Each row displays information for one band and by double clicking on them, it is possible to edit the value:

      • Enabled: Displays if the band is enabled or not for the selected band configuration.
      • Name: Name of the band for the band configuration.
      • Central Wave Length [mm]: Representative (most influential) wave length for the band.
      • Band Width [mm]: Width of the distribution related the central wave length of the band.
      • Weight: How much value Pix4Dmapper gives to the selected band compared to other bands of the band configuration. These values only affect step 1. Initial Processing. The sum of all weights should be 1.

      And the action buttons:

      • Add...: Adds one more band. The number of bands should match the number of channels present in the image.
      • Remove: Deletes the selected row.
      • OK: Saves the new band configuration.
      • Cancel: Does not save the band configuration.
      • Help: Opens the Pix4Dmapper help.


    • Edit...: Opens the Edit Band Configuration pop-up. It edits an existing band configuration:

      By default the values of the RGB band configuration appear:

      Each row displays information for one band and by double clicking on them, it is possible to edit the value:

      • Enabled: Displays if the band is enabled or not for the selected Band configuration.
      • Name: Name of the band for the Band configuration.
      • Central Wave Length [mm]: Representative (most influential) wave length for the band.
      • Band Width [mm]: Width of the distribution related the central wave length of the band.
      • Weight: How much value Pix4Dmapper gives to the selected band compare to other bands of the band configuration. These values only affect step 1. Initial Processing. All the weights should sum to 1.

      And the action buttons:

      • Add...: Add one more band. The number of bands should match the number of channels present in the image.
      • Remove: Deletes the selected row.
      • OK: Saves the new band configuration.
      • Cancel: Does not save the band configuration.
      • Help: Opens the Pix4Dmapper help.



    • Remove: Deletes the selected band from the Band configurations table. 
    • OK: Confirms/applies the changes.
    • Cancel: Does not save the changes.
    • Help: Opens the Pix4Dmapper help.

     
    Example: Examples of band configurations:
    • RGB: For images with 3 bands. The first band corresponds to Red, the second band corresponds to Green, and the third band corresponds to Blue. 
    • Blue, Green, NIR: For images with 3 bands. The first band corresponds to Blue, the second band corresponds to Green, and the third band corresponds to Near Infrared.
    • NIR, Green, Blue: For images with 3 bands. The first band corresponds to Near Infrared, the second band corresponds to Green, and the third band corresponds to Blue.
    • NIR, Red, Green: For images with 3 bands. The first band corresponds to Near Infrared (or Infrared), the second band corresponds to Red, and the third band corresponds to Green.
    • Red edge, Green, Blue: For images with 3 bands. The first band corresponds to Red edge, the second band corresponds to Green, and the third band corresponds to Blue.
    • Red, Green, NIR: For images with 3 bands. The first band corresponds to Red, the second band corresponds to Green, and the third band corresponds to Near Infrared.

 

Camera Model Parameters

The Camera Model Parameters section includes all camera parameters and is enabled for editing if the Edit or New button has been clicked in the Camera Model section. It displays the camera parameters of the selected Camera Model Name in the Camera Model section. 

The Camera Model Parameters section has 3 action buttons (enabled if Edit or New has been clicked in the Camera Model section):

  • Clear: It clears all the fields except image width (pixel) and height (pixel).
  • Estimate from EXIF:  Estimates the parameters from the EXIF data if enough information about the camera model is found there.
  • Load Optimized Parameters: Enabled once at least step 1 has been completed, it changes the camera initial values to the optimized values.

It also has the Shutter Model dropdown list with the following options:

Global Shutter or Fast Readout

To be used if the camera has a global shutter: all light information is read at the same time for the whole sensor.

Linear Rolling Shutter

This option models the rolling shutter (the image is scanned line by line) of some cameras such as the GoPro or the standard DJI cameras. This can be enabled if the camera's shutter is a rolling shutter and, the flight plan is linear (grid mission, building facade, etc.). For more information about how Pix4D models the rolling shutter effect: scientific white paper.

 

The parameters can be defined or edited for a:

  • Perspective lens: When the camera model uses a perspective lens.
  • Fisheye lens: When the camera model uses a fisheye lens (ultra wide angle lens).
  • Spherical camera: Only available when the camera detected is spherical or the height of the image is two times the width. Spherical images are unidisorted by the camera manufacturer and the Image Properites Editor does not present any camera model parameters. For step by step instructions about how to process Spherical images: How to process images of a spherical camera.

Perspective lens

To edit values in pixels, select the radio button on the left of the Image width [pixels] text box. To edit values in millimeters, select the radio button on the left of the Sensor width [mm] text box.

 

Internal Camera Parameters for Perspective lens
Camera Model Name Name for the camera model.
Image Width [pixel] The image width in pixels. This value cannot be edited. It is read from the image file information.
Image Height [pixel] The image height in pixels. This value cannot be edited. It is read from the image file information.
Focal Length [pixel] The focal length in pixels.
Principal Point x [pixel]

The x image coordinate of the principal point in pixels. The principal point is located around the center of the image. The coordinate system has its origin as displayed here:

 

Principal Point y [pixel]

The y image coordinate of the principal point in pixels. The principal point is located around the center of the image. The coordinate system has its origin as displayed here:

Sensor Width [mm]

The sensor width in millimeters. If the sensor width is estimated from the EXIF and no information is in the image EXIF data, the sensor width is set to 36[mm].

Sensor Height [mm]

The sensor height in millimeters. If the sensor height is estimated from the EXIF and no information is in the image EXIF data, the sensor width is set to 36 [mm] and the sensor height is computed in such a way that the ratio sensor width / sensor height in millimeters equals the ratio image width / image height in pixels.

Pixel Size [μm]

The size of the pixel is read from the EXIF data if the information is available. If there is no information related to the pixel size, then it is calculated in order to correspond to 36 x 24 mm sensor size.

Focal Length [mm] The focal length in millimeters.
Principal Point x [mm]

The x image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The coordinate system has its origin as displayed here:

 

Principal Point y [mm]

The y image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The coordinate system has its origin as displayed here:

 

Radial Distortion K1: Radial distortion of the K1 lens.
Radial Distortion K2: Radial distortion of the K2 lens.
Radial Distortion K3: Radial distortion of the K3 lens.
Tangential Distortion T1: Tangential distortion of the T1 lens.
Tangential Distortion T2: Tangential distortion of the T2 lens.
 
Tip: If the radial and tangential distortions of the lens are not known, it is recommended to set the values for K1, K2, K3, T1, T2 to 0. For more information about how to calibrate a perspective camera: How to calibrate a Perspective Lens Camera.
 
Note: For more information about how the internal parameters for a perspective lens are defined: How are the Internal and External Camera Parameters defined?.

 

Fisheye lens

To edit values in pixels, select the radio button on the left of the Image width [pixels] text box. To edit values in millimeters, select the radio button on the left of the Sensor width [mm] text box.

 

Internal Camera Parameters for Fisheye lens
Camera Model Name Name for the camera model.
Image Width [pixel] The image width in pixels. This value cannot be edited. It is read from the image file information.
Image Height [pixel] The image height in pixels. This value cannot be edited. It is read from the image file information.
Principal Point x [pixel]

The x image coordinate of the principal point in pixels. The principal point is located around the center of the image. The coordinate system has its origin as displayed here:

 

Principal Point y [pixel]

The y image coordinate of the principal point in pixels. The principal point is located around the center of the image. The coordinate system has its origin as displayed here:

 

Sensor Width [mm]

The sensor width in millimeters. If the sensor width is estimated from the EXIF and no information is in the image EXIF data, the sensor width is set to 36[mm].

Sensor Height [mm]

The sensor height in millimeters. If the sensor height is estimated from the EXIF and no information is in the image EXIF data, the sensor width is set to 36 [mm] and the sensor height is computed in such a way that the ratio sensor width / sensor height in millimeters equals the ratio image width / image height in pixels.

Pixel Size [μm]

The size of the pixel is read from the EXIF data if the information is available. If there is no information related to the pixel size, then it is calculated in order to correspond to 36 x 24 mm sensor size.

 Principal Point x [mm]

The x image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The coordinate system has its origin as displayed here:

 

 Principal Point y [mm]

The y image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The coordinate system has its origin as displayed here:

 

Polynomial Coefficients

4 different type of polynomials can be selected from a drop-down list, where 1,2 or 3 values are already pre-defined and cannot be changed:

  • 0-1-x-x-0
  • x-1-x-x-0
  • 0-1-x-x-x: recommended
  • x-1-x-x-x: ignores an area around the image center. This is useful when the center is blurry or contains a lot of noise
Camera Model with Symmetric Affine Transformation If selected, the model is symmetric and C=D and E=F=0. This is useful when the circular image cannot be modeled by a sphere.
Affine Transformation C Affine transformation C value.
Affine Transformation D Affine transformation D value.
Affine Transformation E Affine transformation E value.
Affine Transformation F Affine transformation F value.
 
Note: For more information about how the internal parameters for a fisheye lens are defined: How are the Internal and External Camera Parameters defined?.
 
Tip: For more information about how to calibrate a fisheye camera: How to calibrate a Fisheye Lens Camera.

 

IndexInterface > Menu Project  > Image Properties Editor... > Selected Camera Model  Previous  |  Next 
Was this article helpful?
3 out of 3 found this helpful

Article feedback (for troubleshooting, post here)

8 comments

  • Giorgi Lebanidze

    Hello,

    I have projects with multi-spectral and RGB images, taken using SEQUOIA camera (with the sunshine sensor). When processing these images, starting the new project and in the camera model I have two "Sequoia" cameras (in MSP as well as in RGB projects). According to the green icon before the camera name, one is taken from the internal camera model database and another one from the .p4d file when a .p4d file is created (as suggested above on this page). Please see the screenshot of 2 MSP and 2RGB cameras below.

    These cameras have different settings, which I have marked in red on the screenshots below. MSP/RGB camera models from the internal database I gave n1 and MSP/RGB camera models from the p4d file - n2 on the screenshots .

    Could anyone explain why I see two camera models? and could anyone advice which camera model to select for processing? n1 or n2?

    I suppose the camera models from the internal database (i.e. MSP 1 and RGB 1) are main models with the default settings, whilst models form the p4d file (i.e. MSP 2 and RGB 2) are maybe tailored to the particular project and local condition. This is just a guess.

    Thank you in advance for your advice and help.

    kind regards,

    Giorgi

    here are the screenshots:

    MSP 1

    MSP2

    RGB 1

    RGB 2

    Edited by Giorgi Lebanidze
  • Momtanu (Pix4D)

    Hi Giorgi,

    You should use the ones from the database as we have calibrated the camera ourselves, thus the parameters are correct. The cameras from the database will have this cylindrical icon.

    The other one means it is being read from the EXIF. Let me know if you have any questions.

  • Giorgi Lebanidze

    Hello Momtanu,

    Thank you for your reply. So, better to ignore cameras marked as MSP-2 and RBG-2 on the above screenshots, right? Any idea how to remove them form the camera list? because it is set by default and I have to change it manually each time I start the project (which is bit annoying).

    Thank you.

    Giorgi

  • Momtanu (Pix4D)

    Giorgi, that you cannot because it is reading from the EXIF. Most of the times, if the camera is in the database, it will read from the database (and will have that cylindrical icon). If it is being read from the EXIF, you will have to manually change it from the dropdown.

  • Paulo Neto

    Hello, how are you?

    I have a question about the Shutter Model option in Pix4D. We have two options, Linear and Global. From what I understand in linear mode it will consider line by line in the image associated with a camera geolocation, am I right?
    But for example, if I use a Phantom 4 device and a Phantom 4 Advanced device, what would happen if I process the images on Pix4D using the Global Shutter option?

    Why when I use P4 ou P4Adv the Pix4D just show me by standard Global Shutter rather than Lienar Rolling Shutter?

    I have 1 eBee SODA, 1 Phantom 4, 1 Phantom 4 Adv and 1 Parrot Anafi. Wich shutter shuld I choose before processing?

    Edited by Paulo Neto
  • Momtanu (Pix4D)

    The linear rolling shutter distortion comes more into play in the flight height is low and the speed is fast. We have an algorithm that corrects for this distortion. If your camera is rolling shutter and you are using global shutter (which means you are not using the rolling shutter correction algorithm), there might be distortions in the map. However, the algorithm might not correct if there is too much of this effect, so for rolling shutter cameras, we suggest flying high and also flying slow. You can find more info here: https://support.pix4d.com/hc/en-us/articles/208460436-How-to-correct-for-the-Rolling-Shutter-Effect

  • Paulo Neto

    I understand, but effectively how do I know before processing If I enable this option to not waste time processing?

  • Fernanda Bosmediano

    Hi Paulo,

     

    Yes, you can check that before processing it in the Edit camera model. Please have a look at the article that my colleague attached before. After selecting the desired shutter model, you click okay and can run the Run step 1. Initial Processing.

    Cheers, 

    Edited by Fernanda Bosmediano
Please sign in to leave a comment.