Linux dependencies

Warning:This article refers to the command line interface (CLI) and not to the newest version of Pix4Dengine SDK.
We highly recommend migrating to the Pix4Dengine SDK. To get access to the latest documentation please visit Pix4Dengine Server SDK.
 
Information: A Pix4Dengine license is necessary to install the software on Linux.

Supported OS

  • Ubuntu 14.04: official support
 
Note: Pix4Dmapper version 3.3.14 or onwards is required.

Installation

A PPA for Qt5.6 is required before installing the software.  
 
For Ubuntu 14.04 (Trusty): 

sudo add-apt-repository ppa:beineri/opt-qt562-trusty
sudo apt-get update
sudo dpkg -i pix4Dmapper.deb
sudo apt-get install -f


For Ubuntu 16.04 (Xenial, not officially supported):

sudo add-apt-repository ppa:beineri/opt-qt562-xenial
sudo apt-get update
sudo apt install ./pix4dmapper_x.x.x_amd64.deb

For Ubuntu 18.04 (Not officially supported):

sudo apt-get install qt5-default
sudo apt-get update
sudo apt install ./pix4dmapper_x.x.x_amd64.deb

Usage

For more information on how to use the command line: How to use the command line.
 
For advanced users, more functions can be accessed by modifying the .p4d file: .p4d minimum format.

 
Note: Pix4Dmapper requires the HOME environment variable to be set, and the configuration files (licenses, settings) to be stored at: ~/.config/pix4d. The HOME variable can be checked with the command: echo $HOME in the command line. The ~/ in ~/.config/pix4d refers to the home directory defined by the variable HOME.

 

Was this article helpful?
4 out of 5 found this helpful

Article feedback (for troubleshooting, post here)

0 comments

Please sign in to leave a comment.