(Android, iOS) How to fly Phantom 2 Vision(+) and 3DR Solo drones

The support of DJI Phantom 2 Vision(+) is discontinued on Android and iOS, the support of 3DR Solo is discontinued on Android. It means there is no further development for these drones.

 
Warning: These app versions were tested with the currently available firmware by the time they were released. In other words, it is no longer tested with more recent drone firmware, after August 1st 2017. Pix4D disclaims any responsibility.

 

Installation

Android

1. Uninstall current versions of Pix4Dcapture and Ctrl+DJI from the device.
2. Deactivate the automatic update of the Pix4Dcapture app.

2.1. Open the Google Play app.
2.2. Access the page of Pix4Dcapture.
2.3. In top right corner, tap the three-dot menu and uncheck the auto-update option.

3. Download Pix4Dcapture version 3.8.1, click here.
4. Connect the mobile device to the computer using a USB cable.
5. Access the internal storage of the device and browse for the desired directory.
6. Move pix4dcapture_3.8.1.apk to that location. It does not matter where the .apk file is stored.
7. Disconnect the device.
8. Open a file manager app.
9. Browse to find the .apk file. It is normally accessible from the Applications category.
10. Select pix4dcapture_3.8.1.apk to start the installation.

 
Important: There might be some restriction during the installation as the app is not downloaded from Google Play. As it is not the default workflow, the device can prevent from installing Pix4Dcapture. To bypass this limitation:

1. Open the Settings app of the mobile device.
2. From the list, tap Security (or something similar).
3. Scroll until to find the option related to unknown sources apps and allow the installation of non-official apps.

iOS

Download and install Pix4Dcapture P2V(+) version 1.3.2 from the App Store.

 

Flight

1. Plan and fly an autonomous mission following the getting started instructions: 202557269 (Android), 204692015 (iOS).
2. Transfer the images and Pix4D project file (.p4d) following Method A or Method B: 214516203.

 

Processing

The Pix4D project file (.p4d), which is generated at the end of the mission when images are copied from the drone to the device (synchronization), contains accurate image coordinates. Pix4Dcapture does not write in the image EXIF directly. It is recommended to use that .p4d file to process because:

  • P2V(+): Images do not have altitude (not measured by the drone) and planar coordinates are truncated.
  • Solo: Images captured with the GoPro Hero 4 Black or Silver camera do not have coordinate.

 

 
Tip: Without .p4d file, there are some alternatives to georeference a project:
  • Use measured ground control points (GCPs) for high accuracy: 202558699.
  • Use scale and orientation constraints. It does not geolocalize the model but it helps the reconstruction and provide relative accuracy (enough for measurements): 205360375 and 205360385.
  • Use coordinates of points taken from a Web Map Server (WMS), e.g. Daft Logic. They substitute GCPs but the accuracy is not as good. Follow Method B of this article for more information: 115000778603.
  • (Solo) For advanced users, geotag the images by extracting information from flight logs using 3DR Mission Planner.

With the .p4d file

1. After installing the program (download link), click the .p4d file to open the project using Pix4D Desktop.
2. On the menu bar, click View > Processing. The Processing bar opens on the bottom of the main window.
3. Ensure that 1. Initial Processing is selected and that 2. Point cloud and Mesh and 3. DSM, Orthomosaic and Index are unselected.
4. Click Start.
5. Analyze the results and further process. For more information: 202557339.

Without the .p4d file

1. After installing the program (download link), start Pix4D Desktop.
2. On the menu bar, click Project > New Project...
3. The New Project wizard opens. If needed, a more detailed procedure can be found here: 202557369. Otherwise, follow the steps below.
4. In Name: Type a name for the project.
5. (optional) In Create in: Click Browse. On the pop-up Select Project Location, navigate to the folder where the project and results will be stored and click Select Folder.
6. Click Next.
7. In the window Select Images, click Add Directories... and browse for the folder containing the images. Click Choose.
8. Click Next.
9. In the window Image Properties, click Next.
10. In the window Select Output Coordinate System, click Next.
11. In the window Processing Options Template, select the appropriate template either 3D Maps or 3D Models.
12. Click Finish to end the wizard.
13. On the Menu bar, click View > Processing. The Processing bar opens on the bottom of the main window.
14. Ensure that 1. Initial Processing is selected and that 2. Point cloud and Mesh and 3. DSM, Orthomosaic and Index are unselected.

 
Warning: (P2V, P2V+) Without .p4d file, image geolocation contained in the EXIF is imported into the project and as planar coordinates are wrong, it is better to discard them for processing:

14.1. On the menu bar click Project > Image Properties Editor...
14.2. In the Image Properties Editor, under section Geolocation and Orientation, click Clear. This will remove the image geolocation written by DJI and that is not precise enough to be processed with Pix4Dmapper.
14.3. Click OK.

15. Click Start.
16. Analyze the results and process further. For more information: 202557339.
17. (optional) Add GCPs, constraints, or WMS points as suggested in the tip box above.

 

Was this article helpful?
3 out of 11 found this helpful